Attempting Linux Mint

Just making this to document my adventure trying to move to Linux.

System Specs: AMD 2600X, 32Gb memory, R9 390

First I chose Linux Mint with Cinnamon DE, installed it started setting everything up, moving home folder, setting up a caching drive for games, updates, and various other customization’s. Then I went to load some games from steam, loaded a native game and everything seemed great, then I tried to load battlefield 4 through Lutris and it launched fine but was playable but laggy. I then set off to update the GPU drivers, installed some AMD proprietary drivers (terrible idea) and that breaks everything, uninstalled them again and just dealt with the occasional lag.
After this Linus releases Linux challenge I notice Linux used Manjaro, driver support sounded different? Tried a few differnet DE versions of Manjaro and did not like them, went back to Cinnamon Mint, and used a mesa repository (kisak-mesa PPA) for the drivers that it seems like people highly recommend, but I somehow messed something up, wine/proton games don’t launch at all so I am thinking about starting on mint again… Hopefully I can figure this out or I am just going to go back to Windows until SteamOS 3.0 comes out.

1 Like

Well kind of. Manjaro usually uses a newer kernel and drivers are inside the kernel. So by using a newer kernel, u also get ‘newer’ version of the drivers.

On Mint > open update manager > click on third tab named view > click linux kernels > Read warning before you continue > from there the latest kernel 5.13 can be installed. Try that and see if it fixes your problems?

1 Like

If you want a slightly more updated distro if you are considering moving again Fedora Cinnamon is there since you like the Cinnamon desktop.


Gave this a shot, thanks for the suggestion but it seems like it didn’t change anything.

“I broked it real good” haha

The PPA seems to be correct with the kisak/kisak-mesa, so maybe something else is wrong, or maybe I will look for a different PPA for graphics drivers.

It looks the same, if I do try a new OS that one looks like a great alternative. Definitely didn’t realize this one was outdated. When I was looking at different versions of Manjaro, the cinnamon version felt really weird.

Thanks for the recommendation!

You do not need the PPA with the newer kernel. Only for lutris, if you use that? So if you want u can re-install and do the kernel update or of course change the distro. The cinnamon version of Fedora looks amazing, to say the least :+1:

1 Like

Ive read somewhere in reddit that of all the DEs, Cinnamon has the worst input lag of all. About 130+ ms delay vs 30-50+ ms delay on the rest of the DEs.

I havent really tried Mint but that knowledge sort of turns me off. I dont know if this has been resolved or how good the actual methodology of getting the data is but it seems bad enough for me to turn me away.


sounds to me like classic random internet bullshit…

i havent seen any input lag on cinnamon, its quite snapy and games work fine, muffin respects standards so no fullscreen, wine desktop bugs out of ordinary…

one thing that got me to switch to it is really nice boost to laptop battery… gnome or kde is 4-5 hours, cinnamon 6-7 easy…

1 Like

Well it could be. Its just that the person who posted it had metrics and at those millisecond timings, it could be imperceptible to some people.

I wish some Linux youtuber would try to reproduce it.

1 Like

well the best would be to try it out yourself…

from my end, I can tell you that there is no visible lag while using desktop or when playing games…

lap is ryzen 3500u, I use xbox one x controller over usb 2 port, and retroarch ( maximized not fullscreen so desktop compositing is fully active) and nes games run perfectly fine on lap screen… (in ninja gaiden I can usually detect 20-30 miliseconds lag because i know that game by heart)

if I connect lap to TV over hdmi that increases lag a bit ( as it is expected)

also, to be clear, I usually dont use neither mint nor cinnamon ( god himself uses i3 with gaps) and have it installed on laptop purely for uber power management


That’s a curious issue and not sure what the problem could be. I run mint with the 5.13 kernel and kisak mesa ppa and everything works fine. You might want to check that the mesa-vulkan drivers are installed correctly, and that you have 32 bit architecture enabled, I can’t really think of anything else from that. Also make sure the amd-vulkan drivers are not installed, if you have played with the proprietary drivers before, because those might mess things up.

Other than that I suppose you could just wipe the system and reinstall everything, again. :thinking:


I don’t know for sure but I believe it had something to do with Vulcan not being installed or the install was broken.

Another note, was playing around with some different versions of fedora and tried KDE Plasma - super cool gui but sometimes windows would just close for no reason and it was borderline “busy” but overall looked great. Also tried LXDE - was nice and snappy but too basic, no start menu search. I’ll try fedora cinnamon and decide between that or mint. Hopefully I can at least get a non native game running in proton haha.

Update: setup a dual boot system so I can play games with less hassle. Still going to test games and use Fedora cinnamon for as much as I can though.

I have also setup a Dell R610 which was a lot of troubleshooting but fun to play around with. Setup proxmox to try and play around with some stuff on there. Definitely need to learn containers as that seems to be the way things are moving anyways.

Any suggestions for containers or something I should run on my server are welcome!

Hm… how about installing Steam and Lutris via Flatpak? That should take care of whatever dependencies and drivers you need? Though you’ll need to install Proton via Flatpak as well. You can also run Wine using Bottles if you want to and they can use the same Proton Flatpak you installed I think.

As a note do install Flatseal to manage permissions more easily. And a trick that I found to get theming correct is to copy paste ~/.config/gtk-3.0 to ~/.var/app/{each.flatpak.folders} if your theme is available on Flatpak, and just copying the whole theme’s gtk-3.0 folder from theme’s folder (~/.themes, ~/.local/share/themes, or /usr/share/themes/).

$ flatpak remote-add --user flathub-beta
$ flatpak update --appstream

Name                                     Application ID                                           Remotes
Flatseal                                 com.github.tchx84.Flatseal                               flathub
Proton stable (community build)          com.valvesoftware.Steam.CompatibilityTool.Proton         flathub, flathub-beta
Proton-GE (community build)              com.valvesoftware.Steam.CompatibilityTool.Proton-GE      flathub, flathub-beta
Proton experimental (community build)    com.valvesoftware.Steam.CompatibilityTool.Proton-Exp     flathub, flathub-beta
protontricks                             com.github.Matoking.protontricks                         flathub
Steam                                    com.valvesoftware.Steam                                  flathub, flathub-beta
Bottles                                  com.usebottles.bottles                                   flathub, flathub-beta
Lutris                                   net.lutris.Lutris                                        flathub-beta
Wine runner                              net.lutris.Lutris.Runner.Wine                            flathub-beta
Phoenicis PlayOnLinux                    org.phoenicis.playonlinux                                flathub

Personally, I use Garuda Linux for my gaming PC. It’s not particularly stable - I’ve had to reinstall it twice, once because of my own mess up and once because plymouth’s update broke initramfs (pretty sure this is the same issue what EposVox faced). At the same time, I’d rather do that than manually add chaotic-aur or find what apps I need, configure ZRAM, btrfs system restore, linux-zen, latte, etc.

And it’s not a big issue since I keep a list of apps that I install (so I can easily just paru -Syyu --skipreview reinstall everything) and and then it’s just change theme to a more palatable WhiteSur-dark-solid, disable Jelly desktop effect and enable Overview desktop effect - as well as uninstalling steam-native because it doesn’t play well with my setup vs normal Steam runtime.

Also I often move important .config and .local folders like my browser’s, emulator’s (those save data…), Bottles, and Lutris’ to a different drive before just linking it back to /home). This way, if I ever need to reinstall because I borked something or felt like distro-hopping, I wouldn’t lose everything.

1 Like