Return to Level1Techs.com

Asus Z170-WS i7-7700k 64gb ram problem

Hey,

I've got a little problem, built a new rig and everything is fine though for some reason I cannot get all of my 64GB of ram detected by UEFI or Windows for that matter. All the sticks are detected, but only 32GB is shown.
I know maybe Kaby Lake and z170 aren't the best mix, so maybe that is the problem ?
I couldn't wait for z270 boards to arrive though so that's why I went for z170, and this WS board in particular because it has the least of that "gamer" bling on it which I really don't care much about.

According to ASUS this WS board does not support Kaby Lake, but after a few hours of messing around and a BIOS flash I did get it to work, albeit the boot times are terrible, but it works. I basically tried all there is to try with getting the RAM to work, but its still at 32GB.

Any advice ?

Cheers.

You messed with X.M.P. Profiles?

Yes, either on or off makes no difference.

This must be the incompatibility between the CPU and the Motherboard. Seeing how the latest BIOS update for this board was 2016/10/26 and Kaby lake was released on 2017/1/3... :/

Yeah no mention of Kaby Lake support in the manual, BIOS updates, QVL etc.
I guess you were lucky to get it working as is.

Is your RAM listed on the memory QVL in 64GB configuration? If so, have you tried the timings listed?

Lets hope ASUS pushes a new BIOS update to add support for Kaby Lake (proper support).

Last I checked I believe so, have not tried the timings.

The weird thing is when I cleared the cmos when I tried to get them working you get an old BIOS looking prompt with "American Megatrends" asking you to configure the system there it shows 64gb of total memory, but once in UEFI its 32.

I suppose that its a bios issue.
Probably have to wait for a newer bios version with better Kabylake support to come out.
Basicly Skylake supports 64GB of ram aswell, so that shouldnt be the issue.
Its probably just that Asus doesnt have their bioses fully optimized for kabylake yet.