Asus X570 Pro WS ACE Realtek NIC Missing On Boot (Unsolved)

Hi, all!
I’ve been trying to troubleshoot this issue on a system which I use for remote development and work purposes.

Here are the specs -
CPU: Ryzen 9 3950x
Mobo: X570 Pro WS ACE
RAM: 4 x 32GB Gskill Ripjaws V 3000 CL16 (running at 2666 CL16 1.4V)
GPU(s): 2x GTX 1650 Super and 1x GT 640
Storage: 2x 1TB Adata SX8200 Pro and 2x 1TB 2.5" Samsung 860 Evo
PSU: Seasonic Focus GX 650W Gold

I turn it on via WOL during the morning and shut it down from the OS level (Proxmox) around midnight. On boot, the Realtek NIC only seems to be initialised half the time.
It used to work fine on 2 x 32GB of RAM until I added the additional 2 x 32GB kit.

When not initialised, the NIC is disconnected at the “physical” level (no connectivity LED on either ends of switch or port) and can not be detected by the OS at all (no pci device). The only way it can be fixed, but temporarily, is to drain the system of power by flipping the switch on the back of the PSU.

I’ve tried reflashing the bios, downgrading the bios (currently at v3302), clocking the ram at defaults (No XMP), bumping the DRAM Voltage but still see inconsistent results. I have another nearly identical system apart from RAM (2 x 32GB HyperX 3000 CL16) that works fine and I may use it for comparison sake. If anyone could shed some light on this, it would be greatly appreciated!



1 Like

I’m assuming you’ve already tried swapping RAM around to see if one of the sticks is the culprit?

If you can also try the 4 sticks in the other board… maybe its an issue with the board … but if happens to be an issue to have 4 sticks in both… might be the RAM ?

Hi @emcp, thanks for the reply. It seems to be stable as of this moment, but only time will tell. Things I changed:

  1. Rearranged the RAM sticks
  2. Reset BIOS via CMOS (physical reset) before flashing latest ver again (v3402)
  3. Somehow I left the 2x 1650 Supers daisy chained on PCIE Power. Probably was a bad idea. Fixed that too.
1 Like

It’s been about a week with no issues, I’d like to think that a hard physical reset of the BIOS before reflashing did the trick. Probably a bad flash (running 4x32GB Hynix sticks at 3200 while flashing was a really bad idea) caused the issues. Will continue to post more updates if any :slight_smile:

Marking as solved for now

1 Like

regarding your last comment… I was wondering do you recommend you run 1 stick of RAM when flashing the BIOS ? I just got this board and building still… but plan to flash BIOS and have plans for 2x32GB kingston server RAM @ 3200 mhz

There shouldn’t be any issues having both sticks in, but on stock settings (defaults), before flashing. My mistake was probably leaving the Ram OC’d to a “high extent” despite adding much more capacity. As I understand, the higher capacity the DIMMs are, the less luck with them speed wise.

1 Like

Ok, bad news. It happened again this morning after about 10 days of smooth running. Would appreciate any other ideas, otherwise I would start thinking of getting a X570 Aorus Master instead while this goes to RMA…

@WarwicK7 I do have the same issue and I think this is fundamentally a design flaw. Have a look at the other x570 pro ws ace thread.

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.