ASUS Pro WS W790 ACE issue with WD SN770 NVMe drives

Does anyone here have an ASUS Pro WS W790 ACE motherboard and Western Digital SN770 2TB NVMe??
I would guess that possibly the SAGE model might have the same issue since it is close to the same board.

I recently built a Xeon W7-2495X system with this ACE motherboard.
With the original BIOS 0403, the WD SN770 drive is not recognized at all, in either M.2 socket.
I tried two brand new SN770 drives, both not recognized in either socket.

So I flashed the motherboard up to the latest BIOS 0506.
The SN770 is now randomly detected and randomly dropping out of the list of drives in the BIOS.
It can run up to 4 or 5 power cycles and be detected fine, then randomly not detected, requiring one or more power cycles again before it shows up again in the BIOS drive list.

I contacted ASUS Support, and after waiting days for a response, they tell me that my two brand new SN770 drives are both defective.
That would be laughably funny if it didn’t make me stone cold angry.
The issue is definitely the motherboard.
The fact that BIOS 0403 doesn’t even detect either SN770 drive in either M.2 socket is a dead giveaway.

I also have a WD SN850X 4TB drive, and it is properly detected in both M.2 sockets with both BIOS versions.
The WD SN770 is not.

Anyone? Bueller? Or am I just too hopeful that anyone else will have this board and drive…

If I have to, I’ll take the loss on the two SN770 drives and purchase another SN850X drive to replace it.

might make an interesting level1diagnostic video if you want to send one to me to try in my w790 ace.

have you tried explicitly setting the m.2 slot to gen3?

1 Like

Hi Wendell. Do you have your address posted somewhere?
I watch you on your YouTube channel all of the time but I have never seen an address.

The WD SN770 is a PCIe Gen 4 drive, so I never tried setting it to Gen 3, I will try that now.
I just powered-on and booted the system and the SN770 was gone again from the NVMe drive list, so I set the drive slot to Gen3 and saved and restarted and it didn’t show up.
So I power cycled (turning off-on the power supply switch at the BIOS screen) and the drive came back on the next power up, which is what it is doing.
So I will have to cycle the power again a few times to see if it disappears again, and whether going with Gen3 helped.

I always turn my power supply switch off when not using the computer to prevent any power draw, since the board has some components still powered when shut down, to keep my power bill as low as possible (I have eight computers in my home, so they all get powered off at the PSU switch when not in use).
The SN770 will disappear from the NVMe drive list about every six to eight power-on cycles.
If it is gone when I power up, I then have to shut down Windows and toggle the power switch off-on and try again, usually it comes back with just one power switch cycle.
The drive WON’T come back with just a Restart from Windows or the BIOS screen.
I have to totally kill power to the board using the power supply switch.
Then the drive is there for another six or eight times that the system is switched off-on.
Then it disappears on one of the power on cycles again.
If you followed that.

I could try leaving the board powered when Windows is shut down to see if it keeps being recognized that way.
Perhaps the drive won’t disappear if I leave the power supply on, but I doubt it.

The WD SN850X drive is always recognized and in the drive list, even on the original BIOS version.
I will probably just pick up another SN850X drive, since it doesn’t look like ASUS is going to fix this.

It took about 3 months for them to fix the 1tb ram issue too. I can send my address

Yeah, I figured ASUS wouldn’t be too quick.
The thing is though, ASUS Support replied to my support ticket and just told me that my drives are defective and that the problem isn’t their board.
So apparently they have no plans to look into it further.
They probably didn’t even bother power cycling a bunch of times to see the issue.
So I wouldn’t expect any BIOS update to fix this unless some other people contacted them with the same issue, hence my post here to see if anyone else has the same setup.

I am up in Canada, so I can send you the drive through the post.
As I mentioned in my original post, with the original first BIOS 0403 the SN770 is never even seen in either M.2 socket even with power cycling, and with 0506 it is intermittent with power on cycles.
So that should give you some guide for the test.

My best guess is that there is some timing issue with testing for the drive presence, the BIOS is not waiting long enough or something, so sometimes it thinks the drive is not there.
BIOS 0409 was totally off and never saw the drive, and they changed some drive test timings with 0506 but didn’t fully fix the issue.

After setting the M.2 Link Speed from Auto to Gen3, the SN770 drive is being detected all of the time now.
I have tried it with ten+ power cycles so far.
I will test this out over the next day or two and see if it fixes the issue.
Thanks for the tip.

1 Like

You have something to take back to Asus now also :grin:


Just a check-in report that the WD SN770 NVMe is still working fine now after setting the Link Speed to Gen3.
No more disappearing act, for now, I will keep testing it every day when I power the system on.
I sent this information to ASUS Support, no word back from them yet.
It is a Gen4 drive but running it at Gen3 is not noticeable in everyday tasks.

One and a Half Days Later - 2023-08-13 evening
The Xeon W7-2495X computer is still working fine and the WD SN770 drive is still being recognized.
This is after many test power cycles.
So the change to Gen3 Link Speed has apparently fixed ASUS’s BIOS Detection for this drive.
I will post back if ASUS ever replies to my tech support inquiry.



So I am still having issues with the WD SN770 NVMe drive disappearing randomly when I start up the computer from a full power off.
Even with the Link Speed set to Gen 3, it just happens about 30% less of the time.
I was going to buy a new WD SN850X 2TB since that drive model seems to work ok and be properly recognized by the ASUS W790 ACE.
But I just noticed that on ASUS’s website, they have a new BIOS 0705 as of 08/09/2023.

So I flashed the BIOS…
And things got even worse…

Now the system takes 5+ minutes to boot because it is training on the memory (I have 8x64GB for 512GB of DDR5-4800 ECC RDIMM).
And then I get a BIOS Error message that two of the DIMMs failed training, and the system takes the slow boot to only 384GB of memory.
And a reboot just goes through the 5+ minutes of retraining all over again.
I noticed that the 384GB of memory was being trained to higher than 4800, so I figured that might be the issue.

So I went into the BIOS and set the Memory speed to “DDR5-4800”.
Now the system boots correctly again and sees all 512GB of memory.
So ASUS has bungled the BIOS Update again with even more issues.

This board is turning into a really bad investment. I used to be an ASUS fan but now I am getting tired of this.
So I will run the 0705 BIOS for a while to see if it fixes the disappearing WD SN770 NVMe drive issue*

*Note that I had two SN770 drives and I tried them both and tried them in both M.2 slots and tried them in other computers.
The SN770 drives are fine, the ASUS board just randomly doesn’t detect them on a full power cycle.
About one in every five to eight power cycles and the SN770 isn’t there.
Setting the Link Speed to Gen 3 makes the drive show up more often, but it is still disappearing.

The next thing that is happening now, is when I boot into Windows 11 Pro Workstation, it sits on the log in screen for a good minute before it will take my key press from the keyboard to allow password entry.
So now I have to just sit there, which I never had to before.
There are still issues with this system. :confused:

UPDATE 2023/09/08

The latest BIOS update 0705 doesn’t fix the disappearing WD SN770 drive.
It’s gone on power cycle again.

So I’m off to buy another different NVMe drive for this system.
There goes another $200 into this $13,000 CA system… :confused:
I hope that the WD 2TB SN850X works ok, I have a WD 4TB SN850X and it has been working ever since the first BIOS.
I wonder if I should go Samsung or some other brand, but who knows if they randomly disappear as well.

I did contact ASUS about this problem, but they just replied “your drive is defective” when I know 100% it is not.
I have tried two SN770 drives in both M.2 slots and both do the same thing with random disappearing on power cycle.
I am really disappointed in ASUS, I just cannot recommend this motherboard for $1200 CA with all of the issues that it has.

If anyone was interested, the WD SN770 IS in the compatibility list. But it doesn’t work.

1 Like

Have you tried the nvme drives work in another platform to rule out the motherboard?

Have yet to have any issues from my SAGE and it currently has 7 nvme drives hooked up to it, so I’m very curious

Yes, I have tried the WD SN770 drives in another computer and they work fine.
The issue is that the disappearing is random, so how long do I test in another platform before deciding that it is fine?
In the ACE they disappear usually within 5 to 8 power cycles.
In another system here they work fine for 10+ power cycles.

And I tried two of the SN770 drives and they both did the same thing.
What is the chance of having two identical drives with the same identical defect, bought at different times?

I am going to try to get another drive today of a different brand, and put this SN770 permanently into another system here, and see if it lasts long term.

Have you checked if there’s extra standoff behind the board where it shouldn’t be? I’ve had PCIe link training failing due to something similar.

I was very careful when I installed this motherboard to make sure that everything was fine with fit into the Corsair 5000D case.

I just visually checked again right now on the back of the case where the motherboard mounts and there are no extraneous standoffs.

It might be worth trying the nvme via an Asus pcie nvme adding card.

I’ve noticed the Asus brand 4x nvme board works fine here but not the one from gigabyte. Similar pcie perf/integrity issues

1 Like

I would have to order the adapter card from Amazon, our local computer store wouldn’t have any, I live in northern BC Canada with the igloos, where resources are scarce. :slight_smile:
I’m going to check the local computer store when they open in an hour to get a different 2TB NVMe.
I will put the WD SN770 2TB into another computer here, I have seven computers, so I can always make use of it elsewhere.
I realize that this is a newer platform, but I had hoped for more from ASUS on this, especially for the cost of the board.

The drive only disappears when I totally power cycle the PSU. If I just do a reset etc then it is fine.
I turn off the power supply or UPS on every one of my computers to save on electricity up here.
So the motherboard is only losing the drive on a cold detection.
The WD SN850X 4TB drive that I have works flawlessly in either M.2 slot though.

its so freaky because I went through this exact thing on the 3000 series threadripper launch with an asus motherboard but the ace and sage have been flawless for me. I dont have the same nvme but I have a boatload of older toshiba nvme and usually those are trouble. also samsung even 970/80 was a pita on that trx80 board. but since bios updates its been good. as has the ace/sage

If I can get a Samsung 990 Pro or WD SN850X in 2TB, both of those are in the ACE QVL, I will post back if they work ok.
As mentioned, my WD SN850X 4TB data drive has been fine this entire time.

I was irritated that the latest BIOS update messed up my memory training, now I have another BIOS setting that I have to worry about.
And the new issue since the BIOS update with Windows sitting at the login screen ignoring key presses for a minute is really annoying.
This latest ACE BIOS update also has a new Intel MEI driver, maybe that has issues as well for the login problem.

I will try running the WD SN770 for a few weeks in another computer here, and if it runs ok, I might send it to you to try in your ACE board to see what you get with it.

I bought a Samsung 980 Pro 2TB, hopefully that will work, the 1TB version is on the QVL.
I will post back when I get it installed on Monday.
The local computer store only had a Crucial and they didn’t even know what model… :confused:

I use the SK Hynix Platinum P41s throughout my system without a single issue. Love those drives.

The 980 Pro shouldn’t give you any fits, supposed to be really really nice drive.