Assigning network connection for Zoneminder plug (FreeNAS)


I am currently running FreeNAS with 4-port Intel i350-T4 NIC from which I only use one port for all traffic. I use the server mainly as a NAS, and Plex media server.

I am currently dividing my LAN network into three VLANs as I want to separate IP cameras and IoT devices from anything else on the network. I want to incorporate NVR function in my FreeNAS because it definitely has headroom in terms of power. I’ve been looking to use ZoneMinder plugin.

I have read that FreeNAS doesnt support hardware passthru so I cant add second NIC to freenas and use that for IP camera network and zoneminder.
Can I however assign different network interfaces from my quad NIC to different plugins, so that SMB shares, Plex etc would talk to switch through its own interface like now, and ZoneMinder would have its own interface that goes to same switch but different VLAN?

What would be a secure way to build the configuration so that IP cameras are 100% in their own VLAN, and cant communicate with NAS side of things. Dont want anyone to access my NAS from a camera network cable hanging on the outside wall.
Another question would be that if I create new pool and dataset where zoneminder is saving all the video, is it safe to share that as SMB share to computers in my “safe” LAN network, or would that be considered unsafe practise?

Best regards,

So I set current nic to use lacp through 4 ports with my switch, then created 3 vlans and at least the main one works. I tried to put plex server on second vlan but had no luck with it. Not sure if the problem is my firewall or freenas vlan settings.

I’m interested in the networking issue as well. I tried setting up a plex server on 1 network and my other plugins on another, but FreeNAS shit itself when I last tried (over a year ago)

I managed to get things working. Set up 3 vlans in freenas. Plex is in IoT network a d nvidia shield can acces it there, while my own pc and freenas smb shares are in safe network where iot stuff has no access.

I think main problem was old plex version. Updated freenas to 11.2 U7 and the plex to newest available, and then shield was able to find it.

2bitmarksman: best is to set one network interface to be regular for only management, and use another interface for vlans. That way you dont lock yourself out so easily when messing around with the settings.