Return to Level1Techs.com

ASRock X570 ITX/TB3 - booting from T3 does not work

I have this board since few days ago. Currently I have NVMe SSD on the back of the mobo. From there, when booted into Windows 10, TB3 works great for storage. I tried with 3-4 different USB-C enclosures, some with NVMe drives and some with regular old HDDs - all worked as expected.

Where it does not work is booting from NVMe enclosures (USB-C) connected to it. BIOS/UEFI simply does not list them, Boot Menu does not show them, like it’s not there. I am absolutely sure that disk is bootable, tried on a different computer, it appears just fine as bootable option. Tried 2 diff. NVMe enclosures with different disks, 3 different cables, no dice.

Using latest 2.00 BIOS.

Anyone has any idea what could be the issue, what to try…?

Hello, I can’t help you because I am irrelevant. But I am thinking to buy this motherboard because of thunderbolt 3. I have a ryzen 7 2700 and I need thunderbolt 3 for an audio interface called apollo x6…have you git any feedback…?

You have two options:

  1. Get a Thunderbolt 3 NVMe enclosure
  2. Connect the USB C enclosure to one of the USB A 3.2 Gen 2 Ports using a USB A to C Gen 2 cable.

I personally went for the Thunderbolt 3 enclosure as my USB C NVMe enclosure had some compatibility issues with Windows 10 and USB Gen 2 Ports …