Return to Level1Techs.com

AsRock X399 Fatal1ty Professional Gaming "Enumerate all IOMMU in IVRs "

I can’t seem to find the “Enumerate all IOMMU in IVRs” setting in my BIOS. I have been having trouble passing a GPU to a KVM in UnRAID and this seems to be the solution. However, I can’t seem to find the setting I have virtualization, IOMMU and SR-IOV enabled, but I still get crashes with the error “libvirtd tainted”. This is followed by a stack trace which shows that an Nvidia PCI device is the issue. Anyone else with this board experience this?

Is IOMMU set to ‘auto’ or ‘enabled‘? The two settings have different behaviours for GPUs

Enabled. An update after some fighting with this. It seems that UnRAID grabs all of my GPUs at boot for some purpose and won’t release them to a VM. The error it returns is attempting to take device with non zero usage count.

Sorry for the late reply.

OK. and dumb question, is SVM (virtualisation) set to enabled?

Yes it is. I am running KVMs without GPU passthrough just fine. Other people with different Asrock X399 boards don’t have this issue. I have no idea what makes it do this.

Understood. I have the same board and don’t have that error when setting Iommu. I run a vega56 and a rx480 though so it may be a Nvidia problem.