Asrock X370 Taichi USB issues

Earlier today, I noticed that my Corsair keyboard was powered on but not working. Connecting to another USB port worked however upon further inspection I noticed that it would not work on a particular pair of ports with both my mouse and keyboard connected.

I have my mouse and keyboard connected to the USB 3.0 ports on the furthest right of the image. After troubleshooting I realized that once both the mouse and keyboard were connected to those ports the mouse would completely loose power and be disconnected. Once I disconnect the keyboard the mouse regains power and is connected. This problem persists from initial cold boot as well so that should rule out any OS related problems.

With the mouse working, I connect the corsair keyboard next to it:

[ 4689.220598] usb 1-5: USB disconnect, device number 16
[ 4689.220843] xhci_hcd 0000:03:00.0: WARN Set TR Deq Ptr cmd failed due to incorrect slot or ep state.

Which then causes the mouse( device 16) to loose power and disconnect. I then physically disconnect the corsair keyboard:

[ 4713.329035] usb 1-5: new full-speed USB device number 18 using xhci_hcd
[ 4713.745874] usb 1-5: New USB device found, idVendor=04d9, idProduct=fc02, bcdDevice= 3.20
[ 4713.745878] usb 1-5: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[ 4713.745881] usb 1-5: Product: USB Laser Game Mouse
[ 4713.799946] input: USB Laser Game Mouse as /devices/pci0000:00/0000:00:01.3/0000:03:00.0/usb1/1-5/1-5:1.0/0003:04D9:FC02.001D/input/input71
[ 4713.857256] hid-generic 0003:04D9:FC02.001D: input,hidraw0: USB HID v1.10 Mouse [USB Laser Game Mouse] on usb-0000:03:00.0-5/input0
[ 4713.887014] input: USB Laser Game Mouse as /devices/pci0000:00/0000:00:01.3/0000:03:00.0/usb1/1-5/1-5:1.1/0003:04D9:FC02.001E/input/input72
[ 4713.945460] hid-generic 0003:04D9:FC02.001E: input,hidraw1: USB HID v1.10 Keyboard [USB Laser Game Mouse] on usb-0000:03:00.0-5/input1
[ 4714.008374] input: USB Laser Game Mouse Consumer Control as /devices/pci0000:00/0000:00:01.3/0000:03:00.0/usb1/1-5/1-5:1.2/0003:04D9:FC02.001F/input/input73
[ 4714.069204] input: USB Laser Game Mouse as /devices/pci0000:00/0000:00:01.3/0000:03:00.0/usb1/1-5/1-5:1.2/0003:04D9:FC02.001F/input/input74
[ 4714.069370] hid-generic 0003:04D9:FC02.001F: input,hiddev0,hidraw2: USB HID v1.10 Device [USB Laser Game Mouse] on usb-0000:03:00.0-5/input2

The mouse regains power and is automatically connected once more as device 18. I tried swapping around the mouse and keyboard but the same issue persists.

Now if I connect the corsair keyboard to any other USB port on the board both keyboard and mouse works with out issue.I also tried it the other way around and they still both work. The problem only arises when I have both mouse and keyboard connected to those bottom USB 3.0 ports.

At this point I assumed that the bottom pair of USB 3.0 ports may have an issue but then I completely removed the Corsair keyboard from the equation and used a Rosewill keyboard I had on hand for testing. Both the Rosewill keyboard and mouse work without issue when connected side by side on the bottom pair of USB ports. I then tried connecting both the Rosewill keyboard and Corsair keyboard on the same pair of ports and both keyboards work without issue!

One last test I did was to connect the Corsair keyboard and a flash drive on the same pair of USB 3.0 ports. I can see the flash drive constantly connecting and disconnecting via dmesg and the Corsair keyboard back light flashing indicating the same connects and disconnects as the flash drive.

At the moment I have moved the Corsair keyboard to the USB3.1 port so that both mouse and keyboard can work together. I have had both mouse and Corsair keyboard connected to these pair of ports for the last two years. I can’t tell if the issue lies with the specific pair of ports as the problem seems to be created when connecting any device together with the Corsair keyboard on these ports. I have no idea how these ports are wired but maybe the power draw of the Corsair keyboard and another device are two much on these ports?..but then again the Corsair keyboard worked together with the Rosewill keyboard on the same lower pair of ports.

Anyone have any thoughts on this? With my vfio setup, free usb ports are already limited as is…

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.