ASRock Taichi x570 - ECC options no longer in BIOS?

Wondering if I’m overlooking something or if ASRock removed ECC options from their BIOS. I’m on the most recent 4.60 BIOS released 8/5/21. Went to test a new ECC RAM kit with memtest86 as I typically do. I get an error saying

** Warning** ECC injection may be disabled for AMD Ryzen (70h-7fh)

Naturally , I went to the BIOS to enable injection and no ECC options what so ever. I swear I used to have options when I first purchased the motherboard because I’ve tested other ECC Kits the same way.

Anyone have experience with this? Kind of worried now that my ECC is not really correcting errors on account of BIOS updates.

Your motherboard support page is here

Stating

Version 4.60 / Date 2021/8/5 / Size 14.53MB
Desciption:

  1. Update AMD AM4 AGESA Combo V2 PI 1.2.0.3 Patch C
  2. Enable AMD CPU fTPM in BIOS default

It says that the AGESA AM4 code has been update / patched. ok.
CPU fTPM Module has been enabled in BIOS as default.

Perhaps check if there is an fTPM setting that can be disabled. Maybe it messes with ECC ram options. Try setting BIOS to default settings if that doesn’t solve it. Check for a setting that says enable or disable error injection and try both options.

If you say it has worked before the BIOS was updated, then u can be pretty sure it’s been disabled by default. Probably for security reasons.

A simple search also gives some idea as to what the error can be, and it’s usually advised to do that before creating a topic on the matter…

Thanks, I did search quite extensively. posting to a forum is always my last resort.

I noticed the same on the support page, already tried defaults.

Still no ECC options (including enabling or disabling injection)

Hoping somebody that actually has the motherboard will weigh in. I appreciate you trying though

1 Like

Can you downgrade the BIOS? Might be worth checking if a lower version has the option still.
If they do have the ECC options then I would contact Asrock and ask them why it got removed.

3 Likes

Confirmed, the P2.70 version still had the ECC options. I’ll be contacting ASRock next.
Found a youtube video that reviews a BIOS update back in 2019: BIOS Walk through: Asrock X570 Taichi P2.70 - YouTube

Screen shot from the video:

2 Likes

Let me guess the response before their reply; They want you to buy the enterprise stuff for official ECC support?

1 Like

You’re probably correct, without ASRock ever coming out and saying it.
I have one reply so far that either intentionally avoids or just overlooked my request about the ECC injection feature missing. The rep essentially advises me how to check that the OS sees the ECC.

I sent a reply kindly reiterating the original question about the missing error injection feature. we’ll see where that goes. I don’t blame the CS/Tech reps for doing their jobs , they probably just reply based on flow charts and couldn’t actually say the real reason if they knew it.

Was really hoping for an “oh wow, somebody missed something. we’ll try to get that back in a revision” :crazy_face:

1 Like

It’s my opinion Asrock removed ECC support because ECC support on the Ryzen systems is a mixed bag, sometimes it works, and sometimes it doesn’t. Anyway, most people who have a use for ECC will use a server-type board, not a desktop board.

To clarify , ASRock didn’t remove ECC support. The options to adjust ECC related settings was removed. ECC is still recognized and supposedly functional. Just can’t validate beyond a doubt that it’s functioning due to the inability to enable error injection.

What’s the point of ECC memory if it can’t be validated whether or not it is checking for errors. Anyway if functionality is there it can be verifed in other ways, probably through terminal commands or other ways.

Also sales / support representatives go hand-in-hand, nowadays? Making the support part a bit superflous. A bit lol, they actually don’t know and anyone who does know the user won’t get in actual contact with. They are more likely to put the supposed, team-leader through, instead of an actual hired / payed for supporter.

That’s how corporate sales / support divisions work.

It’s a bit annoying and making people rely on other sources than the chip maker. Are people also supposed to get a manual from other places than the manufacturer? Well maybe, also. But not only.

1 Like

Ultimate answer from ASRock is that the availability of CPU related BIOS settings hinges on AMD’s AGESA updates. My understanding of that is AMD removed or disallowed ECC Error Injection in one of their AGESA updates. So, not ASRock’s call.

However, the representative reassured ECC is setup to auto detect and applies regardless of settings available in the BIOS, AGESA or not . That part , I assumed. My only concern was with the missing Error injection feature.

Rep was cool and had patience with me through a few back and forth emails.

If that’s all true, which I have no reason to doubt it, no Motherboard would have the error injection option. Granted , they’re running up-to-date AGESA code.

I don’t like it, but at least we know it’s not some sly move by ASRock.

3 Likes