Asrock MB help!

So I bought a GTX 770 to replace my GTX 650,  on my PCI-express 2.0 Asrock H61M-HVS motherboard, Installed it and it powered on fans, green lights on the card, but no screen image at all.

So put my old card back in and window's wouldn't boot, it would freeze while loading. So I went into Bios and booted up in uefi mode and it worked but it made me delete my HD except for windows. And windows wont detect my speakers anymore, says theres nothing plugged in the 3.5mm jack... but it never moved. Replaced the drivers and nothing.

I RMA'd  the card back to newegg thinking it was toast. But now I'm reading that it my be a bios update problem on my motherboard that needs to be done to make the 770 work. Any insight ?!


Here's the rest of the build.

i5-3350p @ 3.10Ghz

16gig of Gskill RAM

HX850w Corsiar PSU

Windows 8.1

ya just go on another computer with a flash drive and download the latest bios to it and then put it in the computer go in the bios and update it after that I would guess it would work if other people fixed it doing that

Depending on the GPU it may not correctly support newer the newer type of VBIOS. As ragingh4vok noted though if there is a newer BIOS/UEFI for your board you should update to it.


Hope this helps.