Asrock 870 extreme3 r2.0 bios update crash

i was updating the bios via windows 7 and it crashed ( never doing that again) now when i turn no screen or anything.
i tried resetting the cmos, by removing the bios battery for 10 min and pressing the reset cmos button and by putting the jumpers on cmos reset, but still no screen.
anything else i can try?

Sounds like you bricked the mobo interrupting a bios update will brick the mobo (allways update from bios for a safer way of updateing but updateing a bios is NEVER safe)

I'm with cooperman on this. You'll need to reflash your ROM chip.

If it's any consolation, I managed to brick my ThinkPad two days ago when a BIOS update from Windows went wrong. It's been sent back to Lenovo for them to replace the motherboard.

Unfortunatly i think that this board does not support usb flashback, so you will probably not able to restore the bricked bios.

So you probably stuck, and need to buy a new board.

Surely it would still be possible to replace the chip itself?

I found a replacement BIOS chip here, but if OP is less comfortable with buying from eBay, they could always contact ASRock and request a new one. The BIOS chip itself is located between the southbridge and CMOS battery (ASRock Manual, p12), and should be removable with something along the lines of plastic tweezers.


its indeed an idea, if the bios chip is replaceable.

But you have to decide your self, if its worth it or not, i mean that board is realy getting old, it does not have a great vreg design, so an upgrade to a FX 8 core, will probably end up in a dissapointment.

If op has the money, for it, then i would personaly not waste to much time in it, and just buy a newer decent 990FX chipset board.

That's a fair point, actually; I didn't consider how old the chipset is. A new motherboard would be a better option, and would be more "future proof".