ASPeed 25000 -- Boot the host from the SD Card (VMware or other run-from SD hypervisor)

Introduction

The ASPEED 2500. It is everywhere and it is a pretty darn good out of band server management platform thingie.

If you check your motherboard block diagram, you’ll see the ASPEED 2500 has two SD card interfaces, which is usually broken out into one (or two! for raid 1) MicroSD card slots on the motherboard somewhere

The idea is this can be used to record crash videos, SEL logs and other useful IPMI things. Some implementations of the IPMI can also host ISO images which can then be mounted by the iKVM. I think this is possible via ssh but I will have to come back to this later

In some scenario, such as with VMware, it is handy to have this SD card used as a host for VMware ESXi. To get this to work is not necessarily straightforward.

It was necessary for me to wipe and format the card as FAT32 (not exfat and not vfat) to get the card to show in the host. These are the relevant settings under the IPMI interface:

Settings > Media Redirection > VMedia Instance Settings

You must have at least two HD USB images checked if you want the option to use one with the iKVM. The UI/UX here could be a lot more clear as to what is happening.

So, if you’re like me, you initially tried it and it Did Not Work. The ASPEED2500 can get confused by multiple partitions on the SDCard. I had a microSD card I had been using in a USB reader (a system that didn’t have an on-board SD card slot) so I thought it would be plug-and-play with the ASPEED 2500. It was not.

With the change to IPMI settings, disabling power save, reformatting the card FAT32 and then doing a fresh install of ESXi everything worked perfectly.

Hope this helps someone! I saw some folks struggling with the Tyan S8030 and the procedure there to use the MicroSD for the host is much the same as outlined here.

2 Likes

Thank you for this. I discovered I had this option on my Dell T320- modded to T420. It had a dedicated chip for the motherboard to use two SD cards in RAID 1. The problem here is both disks need to be the exact same size. I tried aftermarket SD cards class 10 for industrial use, but they did not work even formatted. I ended up needing to get DELL proprietary SD cards for it to work. Without them formatted to FAT like you said it would lock up my system if they weren’t cleared and didn’t have any partitions. I have ran Citrix off it, but I ran out of time with the controller the last time I logged in. So I didn’t get to mess with Vsphere just ESXI. I dont know what else would be safe to run off of it, but it’s a very cool feature.

1 Like