Arch Linux not detected by Motherboard

I have installed Arch Linux twice on my new PC and each time the motherboard refuses to boot into it. I have an MSI Z390 Gaming Edge AC and have it set to UEFI mode, Disabled Secure Boot, and it still refuses to boot into Arch via grub. Manjaro and Pop os have both installed Properly after abit of tweaking I think it may just be a Motherboard issue but not completely sure

Which part of the guide are you using to install grub?

Just curious, have you tried putting your mobo into bios mode?
Are you dual-booting at all? Some motherboards have you select the correct OS in the BIOS in weird ways.

Disable secure boot.

@washthemhands87 The usual installation method of installing Arch has you install Systemd boot/efistub instead of grub.

I dual-boot Debian SID and Arch. With Debian, I am using grub2 and can boot into Arch with no issues. My prefered method of booting arch is to use the EFI boot menu as I have optimizations with systemd boot that I have just been too lazy to add to the Arch entry in grub.

And to help us further, you need to give a little more information. What happens when the system “fails to boot”? What does your grub entry look like for Arch. Do you have CSM turned on in your EFI options? You see what I am getting at?

And thanks for washing them hands!

Already have

I disabled CSM and have it set to just UEFI mode. It less fails to boot, the OS just doesnt show up in the bios

If your EFI storage is full, (look in efivars), this could prevent adding another entry into the EDI boot loader. I get this issue occasionally with each new Major release of Debian for some reason.

Its a fresh install however (i have attempted to install Arch atleast 5 times now and each time my bios refuses to see it) Manjaro and pop install just fine so I must be doing something wrong but since this is my first Arch install on a uefi system i have no idea what

If you can paste your commands that you use for installing the bootloader we can maybe say what you are doing wrong.

Everything from creating folders, mounting to commands to install and configure bootloader.

mkdir /boot/EFI/
mount /dev/nvme0n1p1 /boot/EFI
grub-install --target=x84_64-efi --bootloader-id=grub_uefi --recheck
grub-mkconfig -o /boot/grub/grub.cfg

I have never installed Arch on a UEFI system and when following the wiki it didnt boot, so I decided to do what I probably shouldnt and try looking at a guide which has led to mixed information

So as I mentioned earlier, the Mostly used way of installing ARCH is to use the UEFI-stub/systemd-boot method. If you are running Grub on the other distros, then installing grub2-discovery will allow them to find the Arch partition and give you a fallback way of booting if EFI-stub/systemd-boot is not working.

I was never able to get grub2 to install on Arch, but that was like 5 years ago.

Now, did you use an iso to install or did you chroot a bootstrap environment to install? If you can point us to the sources that you followed, that would help. If you did not use the official Arch Wiki, then,

1 Like

Ive never used systemd-boot before, although since grub seems to not work Ill try it. I am using the ISO and arch wiki install guide for everything minus install grub since when I installed following the directions via the wiki it didnt boot, instead I followed this video

1 Like

So I watched the video and two things that I did not seem him do since he is running a VM is make sure that you set the ESP (EFI Boot Partition that was formated as FAT) to bootable and also he did not run mkinitcpio as this is what Arch uses to make a RAM disk/initrd.

It is highly likely that one of those two things will fix your boot issue. If you have the live disk, you should be able to mount your Arch drives and mark the ESP bootable and then mkinitcpio with the boot partition active.

Even more so, you may want to try and install Arch in a VM to ensure that it works in the VM. If it does then you may actually be running into a corner case issue. IF it does not work in the VM, then there is something that you are not doing quite right.

Question: do you have a reason for running so many distros? If you are distro hopping and want to use Arch, you may be able to setting for Manjaro as it is the more user-friendly version of Arch.

1 Like

I don’t run many distro’s I run Arch on almost all my systems (minus a Solus laptop) this is just my first time setting Arch up on a desktop “gaming” pc. I installed Manjaro and Pop to see if Linux would boot on my system because I have heard Linux and MSI motherboards dont work well together. I would go Manjaro but there are things I much prefer about Arch over Manjaro

1 Like

I have arch installed this way so this should just work afaik

I’m thinking theres some funkyness going on in bios. Can you use a one time boot menu or a boot override to select the specific disk?

I don’t see options for either, Im almost 100% certain its a BIOS problem as MSI is crap when it comes to following BIOS standards. I switched it from legacy+uefi over to just uefi and my NVME drive normal disappears, so I have had to change boot settings till my drive would show up with uefi

actually turns out I’m a liar. I thought I used grub but that was gentoo… whoops.

usually the one time boot menu is f11 but if its not showing up when you change to uefi only then I’m thinking it wont show up there either.

when going into my BIOS Its set up specifically for Windows (to the point of having settings be labeled “windows os settings”) While Manjaro and Pop OS have both shown to be able to be installed I had to change the BIOS settings to a weird mix of configurations to get it working. Guess I should have expected to run into issues with Linux on a “gaming motherboard” but it seems Arch won’t work with the system

I might be dead wrong though but I have been trying to get arch set up for about 2 weeks now on this damn thing and its always the bios which messes it up

I think you should give systemd-boot a shot.

1 Like