Return to Level1Techs.com

Arch Linux EGPU with Nvidia problem - SOLVED

helpdesk
#1

I’m having a bit of an issue I’m hoping you fine people will be able to help me out with.

I recently got a Razer Core X and was hoping to use my GTX1080ti in it for gaming along with my XPS15 2 in 1. Should be pretty straight forward but I’m running into issues, I’ll list them below.

1.) on Razer’s website I believe this dock is supposed to provide at least 100Watts to charge the laptop, yet mine is complaining about it only delivering 65

2.) when I do not have the Nvidia driver installed the screens come up like you’d expect except I can’t adjust their orientation or order in the gnome settings menu, they revert before the keep changes box comes up.

3.) when I install the Nvidia Drivers the screens do not come up at the GDM login page, and attempting to login to a Gnome on Xorg session results in a login loop. logging in with wayland works, but the screens are still blank, and nvidia settings can’t see the graphics card, yet nvidia-smi does show my card detected, out put below:

if you guys need any logs or any more info please let me know. I’m kinda stumped on these issues.

Thanks in advance!

SMI output:
±----------------------------------------------------------------------------+
| NVIDIA-SMI 430.26 Driver Version: 430.26 CUDA Version: 10.2 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GeForce GTX 108… Off | 00000000:3D:00.0 Off | N/A |
| 30% 31C P5 11W / 250W | 0MiB / 11178MiB | 4% Default |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|=============================================================================|
| No running processes found |
±----------------------------------------------------------------------------+

Error when running nvidia-settings:
ERROR: Unable to find display on any available system

SOLUTION:
Installed gswitch ( Gswitch and followed instructions – took some rebooting, and weird magic stuff that I’m not sure why, but it works now.

1 Like

#2

Gswitch helped with my AMD eGPU. It provides a way to switch between an internal card and external. I only had to run sudo gswitch setup and sudo systemctl enable gswitch. Once you reboot, it selects the right driver at boot by changing your xorg.conf before the graphics target is started.

Another thing you could try if your laptop only has an Intel GPU, is making a second boot entry that blacklists the i915 driver from loading. You can’t use the internal laptop display in this case but external works. To blacklist add module_blacklist=i915 to the kernel parameter

2 Likes

#3

I’ll give gswitch a try tonight, it gets a bit sticky cause I’ve got an intel and AMD gpu inside this laptop already, I’d rather not black list cause I’m still going to use this laptop on the go.

EDIT:
Wait I think I get it now, you’re talking about creating a separate boot option in GRUB to boot with the iGPUs black listed, I get it now so I’d reboot and have the choice of regular booting or booting for the Egpu – not the ideal solution but it that’s what I need to do I will, will see going to try Gswitch tonight first.

0 Likes

#4

The charging for tb/usb-c is finicky there’s a “*” 100watt peak 60watt continuous I have a razer core v1 and it only out puts just enough for the rbs. if I connect a more hungry laptop it will stop charging. Personally I use deepin and has had no issues in switching from Intel graphics to a 1070 w/o reboot lots of flicker while switching. Only tested with rbs though dunno other laptops.

1 Like

#5

ok so I should probably use my laptops power adapter when playing then, I can do that. I’d rather not switch DEs but i can if I have to, will put it on the list of possible solutions though, thanks for the input!

1 Like

#6

Agreed it’s not ideal but does give you the option of exclusively using the eGPU.

Gswitch works well for me except The Witcher 2 Linux build thinks its using the i915 module when its using the amdgpu and the second boot entry gave me a work around for that. You may not run into that issue with nvidia’s drivers but you never know.

2 Likes

#7

when exclusively using the EGPU does it run the builtin dispaly as well or only the monitors connected directly to the GPU?

0 Likes

#8

Only the monitors connected to the eGPU unfortunately.

2 Likes

#9

ehh kinda sucks but not a huge deal, I’ll do some testing tonight and update my post accordingly. Thanks for all your help so far!!

0 Likes

#10

No problem.

Edit:

If you need more help here is where I found the gswitch script.

2 Likes

#11

gswitch seems to have worked - took some finagling and rebooting but she’s working now WOOOT!!! Now to solve the per display dpi scaling issue. Gonna do some googling before I ask about it though. Thanks for your help!!

1 Like

#12

Awesome! Glad I could helped.

1 Like