Arch Linux Artifacting in Select Applications (Plasma)

Having a really weird problem with artifacting in Arch and I can’t seem to find an answer anywhere else. I noticed it a couple days ago using vivaldi. After uninstalling and reinstalling the artifacting was still there. So i decided to try google chrome and that still is artifacting, but firefox doesn’t have this problem. Because of this I though it was something chromium based but then I also noticed artifacting in discord and visual studio code. Nothing else (including intense graphical games like kingdom come: deliverance) has this artifacting problem. How do I fix this?

here are my pc specs:

inxi -Fxz
System:    Host: arch-desk Kernel: 5.1.4-arch1-1-ARCH x86_64 bits: 64 compiler: gcc v: 8.3.0 Desktop: KDE Plasma 5.15.5 
           Distro: Arch Linux 
Machine:   Type: Desktop Mobo: ASRock model: Z370 Killer SLI/ac serial: <filter> UEFI: American Megatrends v: P1.20 
           date: 11/27/2017 
CPU:       Topology: 6-Core model: Intel Core i7-8700K bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 12.0 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 88728 
           Speed: 1200 MHz min/max: 800/4700 MHz Core speeds (MHz): 1: 1200 2: 1200 3: 1194 4: 1200 5: 1200 6: 1200 7: 1200 
           8: 1200 9: 1175 10: 1200 11: 1196 12: 1200 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Vega 10 XL/XT [Radeon RX Vega 56/64] vendor: ASUSTeK driver: amdgpu 
           v: kernel bus ID: 03:00.0 
           Device-2: NVIDIA GP104 [GeForce GTX 1070] vendor: ZOTAC driver: nouveau v: kernel bus ID: 04:00.0 
           Display: x11 server: 1.20.4 driver: modesetting resolution: <xdpyinfo missing> 
           OpenGL: renderer: Radeon RX Vega (VEGA10 DRM 3.30.0 5.1.4-arch1-1-ARCH LLVM 8.0.0) v: 4.5 Mesa 19.0.5 
           direct render: Yes 
Audio:     Device-1: Intel 200 Series PCH HD Audio vendor: ASRock driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Device-2: Advanced Micro Devices [AMD/ATI] Vega 10 HDMI Audio [Radeon Vega 56/64] driver: snd_hda_intel v: kernel 
           bus ID: 03:00.1 
           Device-3: NVIDIA GP104 High Definition Audio vendor: ZOTAC driver: snd_hda_intel v: kernel bus ID: 04:00.1 
           Device-4: Kingston type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 3-3:2 
           Sound Server: ALSA v: k5.1.4-arch1-1-ARCH 
Network:   Device-1: Intel Ethernet I219-V vendor: ASRock driver: e1000e v: 3.2.6-k port: f000 bus ID: 00:1f.6 
           IF: enp0s31f6 state: down mac: <filter> 
           Device-2: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi v: kernel port: d000 bus ID: 0a:00.0 
           IF: wlp10s0 state: up mac: <filter> 
Drives:    Local Storage: total: 6.60 TiB used: 111.03 GiB (1.6%) 
           ID-1: /dev/nvme0n1 vendor: Crucial model: CT1000P1SSD8 size: 931.51 GiB 
           ID-2: /dev/sda vendor: Western Digital model: WD10EZEX-00BN5A0 size: 931.51 GiB 
           ID-3: /dev/sdb vendor: Crucial model: CT250MX500SSD1 size: 232.89 GiB 
           ID-4: /dev/sdc type: USB vendor: Seagate model: BUP BK size: 4.55 TiB 
Partition: ID-1: / size: 227.49 GiB used: 60.75 GiB (26.7%) fs: ext4 dev: /dev/sdb3 
Sensors:   System Temperatures: cpu: 43.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
           GPU: device: nouveau temp: 31 C fan: 1064 device: amdgpu temp: 52 C fan: 1604 
Info:      Processes: 272 Uptime: 46m Memory: 15.60 GiB used: 3.15 GiB (20.2%) Init: systemd Compilers: gcc: 8.3.0 Shell: fish 
           v: 3.0.2 inxi: 3.0.34 

Okay I’ve also noticed artifacting in steam, but only in the right click menu. This is such a weird problem…

Can’t think of it off the top of my head, first thing I’d check for is a setting that tells chrome (and likely pretty much the same in vivaldi) to use hardware acceleration. Check that vdpau (maybe I’m thinking of vesa? idk idc. Give it a look) mesa drivers are installed.

Thanks for the response, I have the vesa drivers installed already, but I didn’t have vdpau drivers installed. I installed it (mesa-vdpau), rebooted, and nothing changed unfortunately.

compositor installed?

Right now I’m using the one that comes with KDE Plasma, which if I’m not mistaken is called KWin.

There should be an option for vsync or some such as well.

Unfortunately barring some changes in how KDE runs (there could have been, not sure at this point. Been with LXDE for a while now.) that’s about everything I’d know to check.

After disabling Vsync altogether and playing with other vsync configurations, artifacting still occurs. I’ve also played with the rendering backend to no effect.