AMDGPU Vega 11 kernel panic

There’s a known issue with AMDGPU and Vega 11 (in my case the Ryzen 2400g) that causes kernel panics. I’ve seen that 4.18 is coming with a lot of changes to AMDGPU, but I haven’t heard if this issue is fixed. Has anyone heard anything or tried it?

1 Like

Is that what happens when the system locks up when I am running my R5 2500U? Or is this a different problem?

Also, 4.18 is out now if you feel like compiling.

Yeah I would assume. That’s what happens to me if I get past boot (system locks on boot a lot too). I know it’s out, but I just switched to my RX 580 and I’m waiting for 4.18 before I try VGA pass through for gaming and really Arch should have the kernel out pretty soon.

Make sure you have latest bios with a recent agesa. 4.18 was flawless for me on the v1000 so I’ll revisit the ryzen g series soon


Does this apply with laptops running the APUs? Since the BIOS on laptops can get rather…“interesting”…

I think I will just update to 4.18 now to see how things improved.

Edit: And…Nope, the computer crashed on me yet again when I was playing Rocket League. So what do I have to do about updating the BIOS?

Edit 2: I ran an update when I was able to remove an old PPA and now things are running more smoothly as I was able to make it for a couple of matches on Rocket League.

I’m using the Fatality AB350/AC Gaming-ITX with BIOS 4.70 which is the latest as of the time of this writing.

I update daily so I’m on the following:

  • amdgpu 18.0.1-2
  • mesa 18.1.5-1
  • mesa-vulkan 18.1.5-1
  • kernel 4.17.14