Return to Level1Techs.com

AMD RX 6700 XT Kernel Driver Support

Just picked up the 6700 XT today and noticed the card wasn’t supported on my current kernel version.

Does anyone know which kernel version has proper output?

Already moved to the upstream 5.11.7 image and my OS still doesn’t recognize my monitor’s supported resolutions.

Have a look at the level1techs YouTube vid for the 6700xt and Wendells 6800xt guide on here, it’s the Linux firmware package with the binary blob that’s needed. Not tried myself yet waiting on my card to get here. :slight_smile:

1 Like

I am currently running kernel 5.10.24 on Regolith Linux and followed Wendells 6800xt guide. I even copied over the navy_flounder firmware files for the 6700XT from the AMD driver installer and still can’t get the amdgpu kernel to load. Do any of you know what else I should check?

Edit: I followed what the review on Phoronix did and used kernel 5.12-rc3 and got the amdgpu kernel mod working.

2 Likes

Awesome, I should have my 6900xt on Monday(fingers crossed) so that’s good to know.

Any 5.10 and above + the updated firmware should work. My 6800xt’s been working great since December.

The latest driver archive can be found here. I was using 20.45 which did not support the 6700 XT.

I’m very interested to know how folks managed to get this working. I’m running Fedora 34 base, onto which I’ve installed the 5.12rc3 kernel from the Rawhide repos. I’ve also pulled the main branch of linux-firmware.git and copied everything into my /usr/lib/firmware directory, and I still get the issues.

Does anyone have any idea what I might be getting wrong?

I am running F33 with mesa git and my 6700XT works pretty well apart from some minor graphic glitches. I thought they come from mesa git but the version from the repos suffer from the same behaviour.

After you’ve put the firmware into the right location you’ll need to run sudo dracut -f but keep in mind that that command will only rebuild the inintrd from the kernel you’ve just booted with.

To check whether it worked do a sudo lsinitrd | grep "navy_fl". If this command doesn’t produce any output you did something wrong, but if not you’re all set.

On another note, does anybody have problems with UEFI only initialization? When I disable CSM and set the GPU to initialize the EFI driver my monitor will go to sleep right after loading the device firmware. Replugging the monitor solves it, but it is really annoying. Windows works fine though. I’ve had an RX6800 beforehand, which I now sold, and it suffered from the same problem. Anyone experiencing the same?

I just managed to get it working by reinstalling the kernel after the firmware was put in place. I have a few minor graphical glitches too, but I’m still running mesa 21.0. I’m going to try to compile mesa-git and see how well that works for me.

Yes reinstalling the kernel triggers dracut and rebuilds the initrd so that’s why it works now :wink:

Don’t bother with mesa git (yet). I tried it 2 days ago, it might be worth checking whether there’s a bug report tho.

Cool, thanks for your help and guidance. I’ll keep a keen eye on this post, see if anyone updates it with reference to mesa-git.

Anyone get OpenCL working with the 6000 series yet? I was able to get my 6900 XT working in Linux Mint 20.1 by updating the kernel to 5.10, updating the firmware, and using the Updated Open Graphics Drivers ppa, but all of the tricks I’ve seen for installing OpenCL support have failed so far, as it requires the dkms module, which fails to build in kernel 5.10.