AMD Reference 6900XT Issue

Anybody know if the HDMI port on these reference model GPU’s is not working or is disabled ?

So I purchased one from and got it installed but no output signal, it looks like the computer is not posting properly.

Running a Gigabyte X570 Master with firmware version f33i
AMD 5800x CPU
Corsair 32GB of DDR4, 3200 speed RAM, 16GB x 2

I even got a new Corsair 850 PS Unit to test with but the same results.

If I place my ASUS GTX 1080 Ti back in I get a proper post without any issues.

I even tried setting the primary PCIe slot into Gen 3 mode to test instead of Gen 4 or Auto with the same results.

I hope this isn’t a faulty GPU but don’t have any other way to test.

I may see if I can dig out my old Intel X99 system from years ago, pretty sure it is store away in a box someplace for testing.

It is of course an older Gen 3 system but it would be a way to confirm the GPU.

Any tips on this as I don’t see any firmware fix for this on the Gigabyte web site unless I just plain glossed over it.


as a side note, I am using an I/O Gear HDMI, 2 port KVM switch box.

Not sure if this has anything to do with it but I know I’ve used older AMD GPU’s on it without any issues.

So to further troubleshoot, I placed the GPU into the secondary x16 slot and now it works and posts and I can boot into Windows just fine.

However the secondary slot appears to be fixed at Gen 4 x 8 :frowning:

This leads me to believe there is something going on with the motherboard and to confirm things I attempted to flash the BIOS, it is failing.

Gigabyte is showing an F36 revision as the latest but it is not being read if I try to use the Qflash utility nor will it flash from using the Windows based @BIOS app.

I have not tried a flashback on a USB pen drive yet but I have my doubts do to the what the Qflash utility is stating, can’t read file.

I wonder why the Primary PCIe slot is behaving this way ?

Maybe it is something with the motherboard or the slot is broken in same way.

Any other ideas ?

Having the same board and a non reference 6900XT, make sure you’re downloading the correct bios for the version of the board, there’s version rev 1.0 and versions rev 1.1/1.2 which have different bios releases, for my board i would normally download the bios update from gigabyte website, unzip it then throw it in the root dir of one of my drives and then flash directly from UEFI Qflash.

Also on the board there should be a physical switch to change between bios 1 and bios 2 so you can try the usb flashback on the second bios if and still be able to boot by switching back to the other.

I was thinking the same thing thanks.

Pretty sure I have the rev 1 board as the F33i BIOS only shows under this revision board and that is what I currently have flashed onto one of the BIOS chips.

So far the secondary PCIe slot is working properly and detects after multiple reboots to test.

I may just leave it this way until the release of the next AM5 platform and see what is available.

But who knows, maybe I will look at the Raptor Lake stuff by that time too.

My father is still rocking an old AMD FX-8350 CPU system with an old RX-380 GPU

So maybe swap out his system with my old mobo + cpu + ram + gpu would be a nice upgrade and I can mess with the BIOS at that point.

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.