AMD Athlon X4 845 not working? (or is it the motherboard not reading it?)

I mentioned this on another form a while ago where I had a problem with getting my computer to boot, I confirmed that there was no problems with my R7 360 (which didn't matter much considering that it was going to get replaced by a GTX 1050/1050 Ti most likely, maybe an RX 470).

I narrowed down what the problem was with the computer when I bought an AMD A4 5300B and realized the computer won't boot when the Athlon X4 845 was in there, but it booted when the A4 5300B was in there even when disabling the iGPU on that processor. I did a BIOS update too in hopes that it would support the CPU.

Long story short, I am stuck with the A4 5300B on that computer until I can get the Athlon X4 845 to work, which sucks so much, somehow I wasn't allowed to overclock it past 3.57 GHz when it was said it could do 4.0. And it's a horribly low performing processor, I got it for $18 for a reason.
It's like comparing a Pentium G3258 to an i5 6600K, except instead, replace it with A4 5300B and Athlon X4 845. It was fast for normal use, but I shiver to think how bad it will do for any modern game, even if it isn't a demanding one.

My motherboard is that MSI A68HI AC.

If I had known it be this much trouble, I probably would have gone with a Skylake i3 CPU, probably would have been the best decision. I think I am going to have trouble waiting for Zen anyways on that build.

You reset the CMOS when you first tried to boot it with the X4, right? If that didn't work then try cutting the power to the motherboard, uninstalling the RAM and any peripherals, then placing the X4 back in as well as the RAM, then plugging your monitor into the motherboard's GPU and reestablishing the power and then clearing the CMOS with the pins located on your motherboard (refer to manual/Google). Then try powering on.

1 Like

Not really, do I reset the CMOS by shorting out a couple of pins?

Yeah, it should either be labeled as CLR_CMOS or CLR_RTC, not sure which MSi had, haven't worked with their mobos for a while. Google should have some information on it's location.

1 Like

Yeah, gonna do that later today. Since I got some work to do. Would I short it out when I press the power button or would I not press the power button. Also, wouldn't this prevent me from booting?

Don't press the power button while you short the 2 pins, just make sure that the motherboard is connected to power. This won't prevent you from booting, all your doing is clearing the BIOS/UEFI configuration, if anything it will help you boot. If you can't find the 2 pins, then flip the switch to 0 on your power supply, wait about 10 seconds for excess power to drain, and uninstall the shiny, circle battery and then install it back in. That'll do essentially the same thing, just with a few more steps.

I suppose that this mobo probably doesnt support that new carrizo Athlon.
It could be that there is a bios update for it to support it.
You could check the cpu support list on Msi´s website to be sure.
If not, then you probably might need a A88X chipset board or so for it.

I updated the BIOS, and MSI's website says that the CPU is supported. So Idk.

If Msi claims support with a certain bios version, and you updated to that.
Then we can take that part out of the equasion.
Do you have a diffrent gpu then the RX470 to test with?

I tested it out with an old workstation GPU a friend of mine I borrowed from and it booted still, as long as I had the A4 5300B in there, but it had problems when I had put the Athlon X4 845. It's strange as both CPUs have the same TDP too (65W), so I don't think it's a power issue. I might have a defective processor, but there were no bent pins when I checked, in fact, my A4 5300B had two bent pins and still worked fine.

The latest version, released on 8-23-16?

If so, your motherboard should be good to go.

Yes, I am at 8-23-16 version.

Hey, was this ever resolved? I can not get Windows 10 to boot for anything. I can install Ubuntu, I can install Windows 7…I can install 59% of Windows 8.1 (then it stalls) Latest BIOS installed…Secureboot settings good…Athlon x4 845, 16 GB 2x8 1600, R9 380 4GB… reset BIOS, nothing works just boot loops…

Hi @tdkryu ;

This is a 5 year old topic already so i don’t think that the solution will be added here.

I highly advice you to start a new topic about your particular issue.
And the community could help you out with tips and suggestions.