AM5 x670e stops seeing boot drive randomly and other glitches!

Hello :wave:
I had my Aorus Master x670e and Ryzen 9 7950x since launch day.

At first it was all fine but since 1.5-2 months ago, every week or so my pc wouldnt boot. I figure out the cause being that my m2 boot drive wouldnt be detected out of a sudden. Thats when the qcode reader on the motherboard give me weird values that when looked up in the motherboards manual would say that they are reserved. So no help at all.

Rebooting the pc would not fix the issue, clearing the cmos on its own also wouldnt help. The only way to get it to see the m2 would be a reboot, a cmos clear, unplug from the wall, let the power drain, and then reconfigure the bios with all of my settings (all of them, including xmp and disabling the igpu, this will be important later on).

After that my pc would boot again. I would update from time to time to new bios versions, even beta, and it would all be ok except these random episodes of not being able to boot every week or so.

Then last Saturday I sat down at my desk, ready to chill for the weekend when my computer wouldnt turn on again. “Ok, lets do the whole cmos reset and power drain” dance and song again. I was wrong. That did show the m2 up again, like it used to, but booting into it would be impossible.

If I tried to boot into windows it would hang on the spinning wheel thingy. Similarly on Ubuntu. On Arch It wouldnt get to lightdm.
Booting even something simple as memtest would hang.

Worth mentioning by this point that in the past months when I had issues I thought maybe the ram was the problem so I did run an 8 hour in depth memtest and it came out fully clear.

First instinct was to think this might be because of that pesky beta bios, so I tried every single bios on gigabyte’s website to no avail. I must’ve reset the cmos and everything 100 times that day.

Some random times the boot process would pass a bit further, for example on an arch live iso, but it would either be incredibly slow, taking upwards of 20 minutes to boot and sometimes being killed probably by some sort of a watchdog.

After discussing with some friends and people online we thought that this is either a broken cpu or a broken motherboard.

I got the cpu from amazon so it was easier to have it exchanged after I explained my issue to a support special on the live chat. The motherboard is from another local company and it would take weeks.

New cpu arrived today. Plugged it in, tried to boot and lo and behold, after a cmos reset, it booted. Be aware this was on a stable, not a beta, uefi version.

All good right? It must’ve been the cpu then. Well, after that I wanted to turn on some setting like the nerd I am, cause thats why I bought this overkill setup after all, right?

Svm worked great. Iommu? Perfect. Disabling igpu? No more boot. Wait what? Yep. After disabling igpu I couldnt boot anymore. I would hang with weird reserved qcodes for the cpu just like before. Not only that but it couldn’t see my m2 anymore either.

Ok, lets do the clear cmos, unplug, all that jazz. I re enabled the igpu and the pc would boot again. Ok, weird. Let me try another thing that I want: XMP. Or whatever it is called now on AMD. They seem to change the name more often than the sockets.

Well it wouldnt boot again with that. Also would stop seeing the m2 boot drive again.
By now you know the spiel. Clear cmos, reset, power cycle, all that.

I thought maybe I should go back to the newest beta uefi like I was on before. Maybe that will help with these two weird issues (not being able to boot with xmp or with the igpu disabled).

Lo and behold updating to the new beta did let me boot with XMP on. Hooray! But wait. It would still glitch out, freeze on boot if I would disable the igpu and it would forget the m2 and all that stuff again.

By this point I just want to have a working computer, so set every other setting to what I like, leave the igpu on for no reason other than to be able to boot and give it a shot. Works.

Ok. Well before it used to break every couple of weeks, never less often than 3. Thats 21 shutodowns. Well lets try to turn it off and on 22 times. If I can do that all is good. Who cares about igpu.

Well after 10 shutdowns my m2 wouldnt show up anymore. Again, clear cmos, power cycle, reboot and then it would work again. So I am back to where I was with the old cpu weeks/months ago.

Will this new cpu also get to a point where no matter what I do wont boot like the last one on Saturday?

Could it be something else I dont know?

Please forum, help me out. I consider myself very technical but this is beyond my debugging skills. Thanks!

P.S. sorry for all the spelling mistakes! I an typing this from my phone for obvious reasons

I was going to say you had a duff drive but it sounds like a dodgy motherboard. Clone your NVMe drive to a standard SATA (using Macrum Reflect) and use that instead just to prove it’s something NVMe related.

Do it soon before it stops working forever.

Yeah. I thought the same. Pc stopped booting fully again but when I had the issues I had them on USBs as well so it’s not just that the m2 disappeared