Return to

Airpods and chromebook audio echo


Was curious if anyone has had this issue

I have a pair of apple airpods (don’t judge, at least not in the open) and a Lenovo chromebook thinkpad 13 codename sentry.

I’ve noticed under Chrome OS the airpods are slightly out of sync, resulting in a echoey reverby sound. The airpods work fine under Galiumos on the same device however, for my chromebook Galium is very slightly broken, so I reinstalled chrome.

Any suggestions on a possible fix or workaround?



It is probably due to higher latency in the wireless audio than direct playback from OS device

My OH has latency problems using powerline network connection to pipe music to kitchen. Running a LAN or USB cable instead would reduce latency, but would still not match latency of onboard audio.

General workaround is to only use one playback device

I can do a better workaround in Linux by adjusting latency offset in Pulseaudio - add additional delay to one audio playback device to synchronise both audio streams.

No idea whether this is possible on another OS



Thanks for the info.

I had a look in chrome os settings doesn’t look like there is a work around. I’ll probably just end up reinstalling Galiumos to be completely honest, but it’s slightly frustrating with the skylake processor. It’ll work great for a day (onboard audio won’t work but bluetooth audio will). but then it won’t suspend when the lid is closed or a variety of other problems (even after updating firmware) oh well. I guess that’s my fault for buying airpods.