ACER Aspire F5-571 - Ubuntu Support [solved]

I bought this laptop about 1 month ago to use for Uni and Web development work while my partner would be on the main rig. I wanted to run Ubuntu 16.04 on it as I think it's better for dev work all round. I had to mess around with secure boot issues but I got it running. But the wifi wouldn't work at all. Would even recognise it. I found a guide that said I had to install drivers from a github repo for it to work. After doing that the adapter could be recognised when I typed in the correct commands in the CLI but it still wouldn't let me connect to a wifi network even if I tried to do it manually.If anyone has an idea on how I can get around this that would be great. Atm i'm using VirtualBox to do my dev work lol.. Any help would be appreciated, Thanks !

Hello I did some shallow searching, the wifi card on the device seems a bit problematic with Linux, or as a person in a Ubuntu thread puts it,,

"Unfortunately, young Dave, you have one of the most difficult, tricky
and stubborn wireless devices there is; sort of reminds me of an
ex-girlfriend. Sometimes, logic and science doesn't work and we throw
the kitchen sink at it!"

however they did a in depth troubleshooting in the thread I suggest you check it out :)

I'm sorry I cannot assist you further since I never have had issues with wifi on Linux,

Best of luck to you

Thanks for the reply, I'll check it out. If it's going to be a nightmare to fix then I think I'll stick with Virtualbox lol. Cheers.

Did a little more digging, if you hasve an old laptop or can find one the wifi card looks to be replaceable, check

that might be worth it to investigate further :)

That does indeed look like it may have a removable wifi chip. In which case swap it out with an intel one.

If you want, open it up and take some high quality pictures of the motherboard for us to see.

1 Like

Reinstalled Ubuntu 16.04 last night and it's working fine now. Must've added support over the past month. Happy user now :-).

1 Like