Accessing Win 8 files with Linux

Hi guys,

I have a friends computer that has an unstable install of Win 8 on it so I said I would help recover the files if I could and reinstall the laptop with Win 7 for her. 


My usual approach in the past was to just boot a usb of Ubuntu or another linux distro to bypass windows and simply copy the files out. With Win8 this now seems to be a problem, I can see the folders but no user files are showing up. 

Is there something different with win 8 that I am missing? I have heard Win 8 might be using the ReFS file system now but only on non boot drives and in the Server version. That is just what I have googled so far at any rate. 

All attempts to stabilise/boot Win 8 have failed so far, testdisk freezes trying to access the file system and I'm about to try the photorec program to scan the whole drive and recover anything it can ( very messy and unorganized, not the preferred option)

Just need the user files out, if any can help it would be much appreciated.





have you tried copying the user folders via the console?

personal folder most likely password protected..

It's probably the bloody hybrid boot "feature" of the Windows 8 crap.

Add the parameter "remove_hiberfile" to fstab on the partition you want to access, and it should work again. I have no idea if that can corrupt data or not (or corrupt more data than usual with windows, that is lolz), because I don't know what Windows 8 does exactly. But if the hiberfile is removed, the partition can be mounted normally again.

If the Windows 8 OS still boots, you can maybe get at the settings and disable fast boot, and then the hiberfile will not be created, and the storage should behave normally after shutdown, which should allow you to access the data without problem from linux.

It might need to rebuild tables though if that's the way it works (which I don't know), depending on what happened, and depending on what's on the partition, that might take a few minutes.

No I have not tried this yet, you mean via the terminal in Linux yes? 

I don't work on many win8 machines, but the ones I have, either booting from linux or plugging the drive into my machine, I have never been able to see any partitions or file systems. 

Lolz, you do have to mount them...

You guys... wtf...

One would assume OP would've done that. Well at least thats what I assumed anyway.

OP yes, it is clear from the OP that the NTFS partition is mounted.

However, the Robots dude's post I replied to, not a chance lolz...

I did mount them lolz omg hehe. The drive would show up unallocated. Using something like gparted or partition wizard would show up with the same results.