Return to Level1Techs.com

A noob having trouble with looking glass

“Waiting for you to upgrade the host application” at the end of “./looking-glass-client”

It loads but this is all I get
version B3-94
any help or advice would be appreciated

NEW NOTE
After saving and exiting virshwin10 line [4] is automatically added
Also, I have a 1080p display so 32 should be correct

[1]shmem name=‘looking-glass’>
[2] model type=‘ivshmem-plain’/>
[3] size unit=‘M’>32
[4] address type=‘pci’ domain=‘0x0000’ bus=‘0x09’ slot=‘0x01’
[5] function=‘0x0’/>
[6] /shmem>

here is a screenshot of the added lines as well as a few extra the pre and proceed the addition (/shmem> to </shmem)

FIX
This problem was fixed by double-checking the downloads to ensure they match and running the program with ./looking-glass-client from the correct directory

The error you get is very clear. The host application and client application must match in versions. If they don’t, the client will wait indefinitely to get a host signature that matches its own version. The best way to get LG working is to download both the host application and the matching client source tarball from Looking Glass - Download Looking Glass, then install the host application in windows and build the matching client on your linux host.

1 Like

Im pretty sure I got matching versions but I will check, thanks.

So i’m pretty sure I downloaded B3-rc1 (185c7764) on the ubuntu host with the grey button but the download says

image

again i’m pretty sure I downloaded B3-rc1 (185c7764) on windows guest with the blue button but the download says looking-glass-host-185c7764

The Log file on the host machine says
‘app.c:456 | app_main | Failed to open the IVSHMEM device’

I updated ‘PCI standerd RAM Controller’ with ‘virtio-win10-prewhql-0.1-161’

That device is now gone and is replaced with ‘IVSHMEM Device’

I disabled secure boot before doing this driver update, maybe it was re-enabled after a restart?

The answer would be no, did a restart into that grey and blue UEFI and checked in device manager/secure boot
was disabled with no [X], it was empty, [ ]

after the restart, I looked at the log again before trying to connect
I saw that ‘Failed to set realtime GPU priority’ and read the comment saying to install looking glass as a service so I guess ill try that.

I will try this command in the shell first
‘New-Service -Name “YourServiceName” -BinaryPathName .exe’

I looked in the services app on windows and didn’t see anything, on the installation guide its says that it now initialized the service at start up but the app itself doesn’t run on start up.

The Log file says says to install looking glass
‘Looking-glass-host.exe InstallService’ pasting this into admin cmd does not help must I use DXGI

You are making it much more complicated than it actually is. All the recent host applications are installing themselves as service. you do not need to do it by yourself. I suggest you to:

  • Clean all the looking-glass host setup you did (remove the service you setup, remove the scheduler job, if you had one etc…)
  • Download the B3 host app zip file and the B3 client tarball (why would you use release candidates?)
  • Unzip the looking-glass-host-setup.exe from the zip
  • Run looking-glass-host-setup.exe on the host. It will install a service to start looking-glass with system account privileges
  • untar the client tarball and follow instructions to build it
2 Likes

I am also having this same exact issue. I made sure that both the vm and the host have the same exact version installed. I even recompiled and reinstalled on both.
I am not sure what this issue could be. I am going to install the previous release to see if I have better luck.

Installing a different version did not resolve the issue. I assume there is something wrong with my vms config.

Please attach your VM’s XML, the client log (whatever is being output on the terminal when you run it), and the host application log (Click Start->Looking Glass (host)->Looking Glass Logs, and attach looking-glass-host.txt)