8gb Total but only 3.99 usable for 1156

I have a new build inspired by Ryan, Wendell and Tech Yes City.

I have an
i5 760
MSI p55 GD65 Bios v1.11
fsp silver 750w
8gb ram
Windows 10 Pro

Ive done all the google searchable solutions. Nothing seems to work. The only things i havent tried is:

-flashing the bios because i dont understand MSI’s instructions on how to flash but ive tried the same method with my gigabyte z77 board. It just doesnt read the bootable flash drive same as the M-flash method

-Use Win 7 as the OS. I think the reason it reads only 3.99gb usable is because 1st gen only has up to win 7 support, although Ive tried both Win 10 & 8.1 and both has only 3.99gb usable.

Ive also happened to make it read 8gb total usable but after rebooting it returns back to 3.99gb usable.

Btw, this only happened when I freshly installed a new OS then I tried to run Witcher 3 and it was so laggy. Although the 1st time ive tested the system after buying it from the previous owner, I was able to run FFXV, with my boot ssd, just fine

What is the voltage of your ram ? An issue brought up here …

theyre generic kingston rams @ 1600mhz. Im out of town atm, i think it’s 1.5v

You ARE actually running 64 bit windows, yes?

1 Like

yes sir

OK, just had to make sure, carry on :slight_smile:

This is 8 GB configured as 2x4 or 4x2?

Its possible (at a guess) maybe one of your memory channels is broken either on the board (trace) or CPU socket or perhaps one (or more) of your slots is broken.

I’d try and re-seat the memory, if you’re running 2x4 maybe one of the chips isn’t quite seated properly.

If that doesn’t work try different slots.

If that still doesn’t work, i’d try one stick at a time in slot 1, to verify that all your memory sticks do indeed work (i.e., with memtest86); it’s possible (again if you’re running 2x4 that) one of your sticks is totally dead or dodgy.

Might take a while, but just take your time and attempt to rule out each component.

If you do find that one or more of your slots don’t work, its possible there’s damage to either the slot or maybe even one or more of the pins on your LGA socket.

it’s 2x4. And the bios detects 8GB even the OS detects the same but only has 3.99GB usable. I also reseated still same resultsI installed the Win 8.1 & 10 64bit myself, on two different drives and same results.


I’d be looking through your bios for options relating to 64 bit support or memory support.

It may be that somehow your BIOS is telling the OS that this memory is mapped for something else.

It might be worth giving this another ago, I don’t see BIOS 1.11 listed on the MSI support site so I am wondering if it might be 1.1 or even 1.1.1 (Unless they are displaying BIOS 1.B in decimal in BIOS setup) … if so there are some interesting memory related updates in BIOS 1.4 and 1.5

BIOS 1.4

  • Update CPU micro code.
  • Improved memory compatibility.

BIOS 1.5


  • Update CPU micro code.
  • Update NB module.
  • Update M-Flash module.
  • Fixed system report incorrect memory size when install 8G memory.

The BIOS updates I have found are here. The manual for the board is also available on the site and gives an overview of updating the BIOS (I found a video demo but it looks like it’s for a later UEFI BIOS)

Maybe worth a try.

did you already checkout if the max memory at bootup isnt deselected in msconfig?

yes i did

I really think the solution to this is updating the bios but I dont understand how the M-flash module works. Ive used the same bootable flash drive (to install the OS) but It just says it doesnt detect a boot OS on the drive instead of going to the flash command prompt/DOS or something

btw, i also tried use the msi live update for flashing the bios. It says the BIOS has the latest version when searching for an update, but its obviously not. It’s really fvcked up, i never knew this old platforms were a huge mess

Can you confirm the BIOS version again? If it’s 1.11 then I think it’s the latest because the last BIOS listed on the MSI website for your MB is BIOS 1.B and ‘B’ is decimal 11 in hexadecimal.

Can you check the BIOS release date?

i didnt know that. Well, im pretty sure I read v1.11. But i have to reconfirm it. But if it is indeed 1.11 then what could be done to fix this if it already has the latest bios?

Just to be sure, when you re-check the BIOS version take note of the release date too, BIOS 1.B was released on 2011-08-18

If a bios update didnt fix the problem,
then maybe you could try to do a hard bios reset.
Just unplug the system from wall power, take out the bios battery on the motherboard for a few minutes.
then re-seat the memory, and put back the bios battery again.
Then see if that might fix the problem, but dont forget to set date and time in the bios firstlly before booting to windows!!!.

i see. Thing is i left the unit on my brother’s in the country side, so he’s gonna have to do it. Btw, Is that gonna delete my OC profiles?

Yes it will.

I can see latest version is 1.B too

Support For P55-GD65 - BIOS

There is youtube link showing how to copy BIOS to USB and update

earlier v1.6 BIOS - “Fixed system report incorrect memory size when install 4G memory”