6-lan fanless mini pc / not a build

Not sure whether this thread (not being about a build but problems with a barebone) would fit here (or where), but wanted to ask to see how I would isolate the problem before contacting manufacturer :

Subject is a barebones including wifi card fanless Hystou i3-7100U 6-lan mini pc purchased via Aliexpress (similar pc link):

As the pc was barebone, I first bought memory for it :
2 pieces :
RAM for laptop Crucial DDR4 8GB 2133MHz CL15
8GB 2Rx8 PC4-2133-SB1-11

Since 22.1.2018 when I installed Windows 10 on a Samsung 840 pro ssd, the following issues have occured:

Blue screens:
-Memory management
(haven’t noted all bluescreens that have occured)
PC turns off (black screen) (1 time)
AMI Beep codes on startup (1 longer/3 shorted - as far as I see this indicates memory fault ) (at least 5 times)

On 22.2.2018 I opened the pc and re-seated both memory modules a couple of times to make sure there was no problem there.

After that :

  • a few more of the same beep codes
  • no reaction from mouse/keyboard and some strange shading marking on screen (several rows of it horizontally)
  • about 10 rows of squares which move horizontally (two times)
  • press button on pc, led turns on, but no boot sound
  • reboots by itself (several times)

Strange, I’ve never had a pc with such a combination of problems - and now it’s been turned on for several hours and it’s working without problems

Anyone care to take a stab as to what I should do to identify source of problem - pc has been working
now for a couple of hours again without problems. Should I do some memory stress testing or
do the problems indicate something else - I’m unsure what to do

Spoke too soon - blue screen KERNEL_SECURITY_CHECK_FAILURE occured and pc rebooted.

The weird screen with rows of squares (similar to some video test on top of what was on screen appeared)

and I couldn’t stop it / unplugged the pc.

Is it getting hot?

Test each dimm (single dimm).
Depending on results perhaps try in second dimm socket.

Have you checked if there is a bios update available?

In every one of thse troubleshooting threads I say the same thing:

Step 1: TEST THE MEMORY. Use Memtest86+. This is usually the problem.
Step 2: Test the drive: Use CrystalDiskInfo or SMARTmontools to check to see if you have SMART errors on the drive. (probably not your issue)
Report back on those and we can take it further.

wonder if it is the Intel microcode updates that got installed by windows which broke it

Had all this crap on an older i7 which worked flawlessly for few years , tested, tried everything (think) and finally surmised it was a mobo fault. If its still under guarantee try and return it