4k 60Hz over DP on iGPU i7-4790K (Arch linux)

Hi all!

For some reason I just can’t get my 4k TV (which I’m using as a monitor) to run [email protected] in linux, using my iGPU. The TV has only HDMI inputs - I have active DP 1.2 to HDMI 2.0 adapter which works fine (used it a lot with my old GPU - GTX 970 in a hackintosh build, also tested on GTX 1070 on linux and windows).

In windows, can run run [email protected] using iGPU, but only after I add a custom resolution using Intel’s drivers. I’ve tried to do the same undex linux, but that’s where I’ve failed. Whatever I try, I just get “No signal” on the TV.

First, I’ve tried adding a custom mode for the regular [email protected] signal:

cvt 3840 2160 60
# 3840x2160 59.98 Hz (CVT 8.29M9) hsync: 134.18 kHz; pclk: 712.75 MHz
Modeline "3840x2160_60.00"  712.75  3840 4160 4576 5312  2160 2163 2168 2237 -hsync +vsync

xrandr --newmode "3840x2160_60.00NR" 712.75  3840 4160 4576 5312  2160 2163 2168 2237 -hsync +vsync 
xrandr --addmode DP-1 3840x2160_60.00NR 
xrandr --output DP-1 --mode 3840x2160_60.00NR
xrandr: Configure crtc 0 failed

That just fails with Configure crtc 0 failed error message. After some googling, I’ve concluded that integrated GPU does not have enough bandwidth to run full [email protected] signal. Not sure if that’s true or not, but I believe I’ve got the similar error under windows. After that I’ve tried adding a new mode using reduced blanking. This works fine under windows, but not under linux. Here’s what I’ve done:

cvt -r 3840 2160 60
# 3840x2160 59.97 Hz (CVT 8.29M9-R) hsync: 133.25 kHz; pclk: 533.00 MHz
Modeline "3840x2160R"  533.00  3840 3888 3920 4000  2160 2163 2168 2222 +hsync -vsync
export X="3840x2160_60.00R"; xrandr --newmode $X 533.000000 3840 3880 3920 4000 2160 2165 2175 2222 +HSync -VSync; xrandr --addmode DP-1 $X; xrandr --output DP-1 --mode $X

After running the commands above, all I get is “No signal” error on the TV. I’ve compared timings I got from cvt and Intel driver, and they are different. They also use different terminology. I’ve tried a lot of variations to the timings I’ve got from cvt, but non have worked. I’ve also tried what I think works with Intel drivers under windows, but it also didn’t work.

I’m not sure how to proceed or where to look, any suggestions?

I added the helpdesk tag to help people find your thread better. Thank you for providing lots of information.

This is anecdotal at best.

I remember when Wendel was reviewing the surface 2? Or was it 3? he had continual gripes about the 4k output of the iGPU and that was under windows (ideal condition) with the ever lasting hope that it would be fixed at some stage.

I can report that even at 1080p on a 4k screen on the 6700HQ with an Iris Pro 580 it still black flickers in a way that would make nVidia jealous wishing they could market the downfall of monitors in general for their own tech.

So if it is still a crapshoot under windows I have no hope for Linux.

This may be a permenant issue that will never be fixed.

Sorry I cannot help, just adding background that may be semi relevant.

Thanks guys. I see, I might have to give up on this one :frowning:

Oh no don’t take that away as the end all. There may well be a work around, just historically the iGPU on Intel stuff has not played well with 4k.

It would be of great benefit if there was any inlmprovement to take away from this. So just because I am a naysayers d9nt let that end it.

Ah a thought hit me. When watching the L1 news have you noticed that sometimes one of the monitors flickers. That’s a NUC as far as I know again having trouble with 4K on its iGPU.

I’ll of course try any suggestions I get here, but I’ve spent a bunch of time on this and just don’t know how to proceed. I’m not sure if it’s iGPU issue or something with my TV or combination of both. Maybe i915 driver has issues with reduced blanking signal? No idea, and don’t know how to continue debugging.

I forgot to mention that I can drive 4:2:2 signal @60Hz without any issues, but that ofc is not usable for computer monitor.

Can I ask why? I know it is not the full banana, but is it that bad. I am not a super visual fanatic guy by any means but I believe my main monitor is only capable iof the same, granted it is a 1080p monitor too but I have never seen any issue next to the “video professional” iPad screen to DP board I have connected too that does do everything and in IPS quality.

Though I fully understand if it does bother people as I have my own peculiar annoyances others don’t see, just none that relate to this.

Most of my time spend behind a monitor is for writing code. Text just looks sooooo bad, especially when you’ve got syntax highlighting (like you’re looking at a highly compressed JPEG). I just find it too distracting.

1 Like

Ah I get you, that was one specific point where 4:2:2 fails badly. Makes sense.

Edit: okay I am hopeless at all the command line style stuff so I apologise if this is what you all ready have above.

I did a quick look and there is a topic on Intel’s forums about 4k 60hz and sound issues under Linux. He I itially had 30hz just fine and managed to make a 60hz option like you have been trying to. They report success so it is worth a look.

https://forums.intel.com/s/question/0D50P0000490WDqSAM/4k-60hz-on-linux-on-nuc7-and-audio?language=en_US

I’ve never had success driving a 4:4:4 chroma 4k 60hz signal from anything haswell. Even in windows. I hate to tell people to throw money at a problem but a GT1030 or RX560 might do wonders here.

Just a thought.

1 Like

@Zibob Sorry for not replying earlier, I didn’t have any spare time to spend on this. Thanks for the link, I’ll definitely try those in a few days. I haven’t tried that combination of the timings yet.

@Adubs Yeah. For now I’ve just given up on GPU passthrough - I’m running my GTX 1070 and dual booting windows for VR. If I ever decide to revisit this, I’ll buy a lower end GPU which is capable of driving [email protected] (if the timings from above link do not work).

1 Like