3080 no display out on my 1950X/X399 Taichi Build

Hey guys I could really use some help.

So I was able to get my hands on a 3080 Amp Holo to upgrade from my 1080ti. Unfortunately though, I can’t get it to work with my build. My 1080ti however is still working perfectly fine, but I really wish I could make this upgrade work.

Nothing out puts to the display and I get a D6 error from my motherboard. So the GPU isn’t getting detected. It does the starting light animation on the card, RGB starts up, but get nothing on the display. When I placed it into the first PCIE slot it would trip the PSU as soon I push the power button on either the mobo or the case. At one point in first slot I got the lighting animation and RGB turning on but then when I moved the card to see if maybe PCIE slot is not detecting the card, PSU tripped again.

Things I’ve tried to get it to work, and nothing could get it to show on the display:

  • All the different PCIE slots on my mobo (X399 Taichi).
  • Updated the bios. (currently on 3.9)
  • Made sure that old drivers from the 1080ti were uninstalled using DDU.
  • Changed the 8-pins back to the stock ones.
  • Made sure that I’m using 2 separate 8-pin cables.
  • Did a CMOS reset.
  • Tried with Ethernet both connected and not connected
  • Made sure drivers for the new GPU were downloaded but NOT installed in most recent test.

I took the card to test in my brother’s build and it worked no problem.
His Current build info:

Let me know your guys’ thoughts and if you have any random fixes that I should try.

Here’s my current build information:

Additional Info:

  • When testing Ram was set to 2133, 2733, and 2800
  • Currently using Bitfenix Alchemy 2 Cables for the build, but again switched cables back to stock EVGA cables in order to rule out cables as the issue.
  • NZXT AER Fans are not plugged in; they are strictly there for RGB purposes.
  • Not included in PCpartpicker list is NZXT Internal USB Hub.
  • All peripherals were unplugged when testing (including internal ones), with only mouse, keyboard, and either or both monitors connected. However some test were tried with internal peripherals (NZXT USB Hub & Hue+) connected.

try the board in legacy mode and UEFI mode, disabling and enabling csm

Are you sure you’re using the right 8pin for the power? You have a modular PSU so I’m wondering if the cable is either wrong pinout or plugged into something meant for the CPU header. Not all manufacturers do the same thing here.

Yeah the pcie power could be running the gpu lights and what not and the supplemental power could be whats not working. Could just not be plugged in all the way on either side as well

How do I go about doing this? Never heard of this method before, and I’m still relatively a noob when it comes to PC Troubleshooting.

So here is where I have my cables plugged into, and I made sure that my custom cables and stock cables were the correct pin out, and plugged in all the way on both the PSU and the GPU. My 1080ti has been using the customs ones for years with no issue, and also ran perfectly fine when using it with the stock cables when I was doing test to get the 3080 working. I also double checked that the 3080 was securely mounted into the PCIE slots when I was testing it as well. I normally have the case laying flat whenever I insert a GPU to make sure gravity helps me have nice and seated all the way in the slot.

I also double checked that the CPU power cables were also the correct Pin out to make sure that wasn’t the case as well. Nice part about this cable set I have each case is individually boxed stating what it is for and they separate the CPU 8 pins into 4 pins on the nd that goes to the mobo.

I appreciate all the help guys, and please let me know if you have any other ideas that come to mind in regards to getting this thing working.

I’m straight up out of ideas then. Thats baffling. I wonder if its something to do with PCIe power draw? I really have no idea.

@SoulFallen you ever seen anything like this?

Sounds like a bad card but there’s a few more things that could be tried.

3080s are not compatible with legacy.

You could try changing the pcie version from 3.0 to 2.0 see if anything changes. I doubt it but compatibility issues make this a thing sometimes. If that were to fix it then the bios probably needs updated to something that doesnt exist yet.

Might sound stupid but make sure the retaining clip on the card is actually clicking shut when you slot it in sometimes some cards aren’t a perfect fit with certain case/board combos.

When these go bad they cause seemingly random havok due to backfeeding power into the board, try unplugging it to rule it out.

I don’t think there’s anything I haven’t seen at this point and it terrifies the depths of my soul


Oh I always double check that the clip is clicking and it does make an audible click when its in there. Like I’m pulling up on the back of the clip make sure it’s secure.

Regarding changing the PCIE to Version 2 I’ll gave that run, and if it works that way I’m wondering how bad the performance hit will be. Also regarding the NZXT hub, I have tested with it unplugged along with the NZXT Hue +, still nothing.

Personally speaking I don’t think the card is bad, mainly because it did work with no issues in my brother rig. Granted, his is newer than mine, but I’m starting to think that the issue is my mother board or the PSU just not having a enough power to control the voltage spike with the new card. I mean it should all things considered but yeah.

One thing that I’m planning on trying here is the two other VGA ports and see if that makes a difference, as I haven’t tested that out yet.

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.