2FA doesn't work

Hey guys! It’s my first time posting here, so I apologise for any errors. I just signed up and went to activate 2 factor authentication, but I always get a ‘Invalid Two Factor Authentication Code’ error. Am I doing something wrong or is it a known bug?

I received the error as well when I tried a few days ago

It may not be set up on the backend. @wendell?

With that said, the 2FA feature was just added to the 2.0 branch of discourse a couple of weeks ago, so new, it wasn’t even in the release notes as far as I can tell. :smiley: So there may be bugs as well.

Yeah it’s broke in iur version will try to pull an update in a bit

this miiiiight be fixed now. maybe.

lets see

Invalid code still @wendell for me

1 Like

No bueno

1 Like

Did you just drop the secret key into the code field? :smiley: :laughing:
That’s not how that works
Try 008990
20 seconds to go :smiley:

lol so this might have been a clock/time issue. blushes
try now?

also what catsay said

tried it again and apparently the code isnt auto generated everytime so I hope no one guesses my password or else they get 2fa…

No dice.

1 Like

ok I forgot to do the scan with a phone thing for google auth, did that now, still poo

Something of note, it’s still using the old secret key from my earliest attempt.

I feel like discourse should be generating fresh keys when you try to set it up again. :thinking:

ah yeah we may have to wait 15 mins or so
the clock on the master server had drifted 15 mins into the future


May I ask:
How did that happen?

No regular NTP sync?

Just tried and it worked for me

Confirmed working @wendell


Also did a login/logout to make sure.

1 Like

yeah, was the time issue. glad it wasnt hours out of date lol

forgot but not everyone might have nbeen hitting the same server too. I changed the main one but it might have taken a bit to sync up the other instances

1 Like