Return to Level1Techs.com

10th Gen / Ice Lake and Linux, no HDD/SSD

Hi all,

Got a query and the guys over at the LTS Discord server suggested that you fine people might be the ones to ask.

This is a bit of a cross post from the Clonezilla forums so apologies if anyone happens to be in both.

I’ve got a brand new Acer A317-52 laptop which came factory fitted with a HDD. My normal process is to backup the OS before doing anything and then dump a clean windows 10 image onto the disk to get rid of all the OEM and MS installed bloat.

Booted clonezilla fine using UEFI from a USB stick, the system found my external 2tb disk and mounted it as the image store but it would not find the HDD.

Went to the BIOS, disabled fast boot, disabled secure boot, found the “press ctrl + s on the main bios page” secret options and changed from “Optane without RAID” to “AHCI”, booted clonezilla, still no dice.

lspci shows a “SATA controller: Intel Corporation Ice Lake-LP SATA Controller [AHCI mode] (rev 30)” so it looks like the OS is seeing the controller and likes it but lsblk only lists a loop device and the memory stick I am booted from. lshw -c storage also shows the Intel Ice Lake-LP in AHCI mode.

Tried with several versions of Clonezilla, currently running 2.7.1-15 and Ubuntu 20.04 + 20.10.

Any other ideas anyone can come up with?