Zotac GTX 970 4GB causing PC to crash and enter a bootloop?

Zotac GTX 970 4GB
Ryzen 5 1600
Gigabyte GA-AB350-GAMING 3
Corsair Vengance LPX (2x8) 3200mhz
Corsair CX600M

So I recently just purchased this card from Craigslist. When trying to install an operating system (Win 10, Win 8.1, Ubuntu, Fedora), I always run into errors.

Ubuntu and Fedora just refuse to install when this card is inserted. With Windows 10, it will install, but then maybe after 2 min into the desktop and it crashes and enter a bootloop. Afterwards if I hard reset the PC, the moment I reach the login screen it crashes again.

Win 8.1 was a bit better. It seemed to run fine until I tried to install NVIDIA graphics drivers, which was the first thing I tried to install. The only OS that seemed to have little to no issues was Deepin OS, and even that had issues installing new software and updating - plus I would like to use Windows for this PC.

The strange this is that none of these problems exist when I take out the card and replace it with my old EVGA 750ti SC. With that, the PC is as normal as can be.

I checked it if was the 2x 6pin power connectors, and they are firmly interested into the GPU. On the BIOS, I checked the Advanced Voltage Settings, and the CPU Vcore, 3.3v, 5v, and 12v listings all reached their perspectives voltages.

I checked both sticks of memory I had, and neither of them caused any problems.