Z97-WS PCIE X1_2 issue detecting card on restart

So i have been having this issue with my Z97-WS for 3 months now, i have tried to google and ask LTT forum with no luck. My new Z97-WS does not detect my X1 card when I restart my windows. Sometimes it will detect on a cold boot or if i switch PSU off and on then boot, that is if windows don't freeze during windows splash screen. I have tried every possible PCIE setting in the bios and updated to the latest version of the bios. This issue was not present on my old Z68 Deluxe MOBO with the same hardware besides the MOBO and CPU. No matter what PCIE X1 card i put in in witch ever slot it fits in, it will do the same.


CPU G3258 till 5775C comes out
PSU HX850i
GPU 980 in top PCIE X16 slot
SSD OCZ Revo X2 in X4 PCIE slot
WiFi in second X1 PCIE ( ASUS PCE-AC66 )
OS Win 8.1 Pro 64bit

I had a rig with the WS board and I have the same problem, I could never get it to work either :( I hope someone can help

Hopefully it's not incompatible with the board.

So its not a bad board? I really like the new WS Z97 board, i really don't want to get something els because of this issue. I hope asus is able to fix it by a bios update. At least its good to know that im not the only one. What board was it?

Ya, I think its something they should fix with a bios update, im hoping next one, im running 2304 atm

The problem is kinds fixed. The PCIE slot works every time i restart or power on but, for it to work every time i have to go into bios and leave port 1394 and 2nd lan port enabled. WIERD, how does that have anything to do with it.

chipsed provides 8x pcie 2.0 lanes but some may be used for onboard sevices such as usb ports or lan ports and it will leave you with less lanes, it depends on the board itself.And some slots share bandwindth meaning when you plug device to one slot others will be disabled.For example SABERTOOTH Z77 , has some pcie 2.0 x1 slots and one pcie2.0 x4 slot but if you plug anything into x4 slot ,x1 slots will be disabled. Other option ,according to manual pcie x4 slot shares bandwith with usb3_ E56 port on the i/o panel check manual and make sure there is nothing connected there and check then.

Oh, ok. I do also have a PCIE SSD in the X4 slot running at X4. My old Z68 board I was able to disable both lan ports and 1394 with no effect on my PCIE X1 slot. I guess asus changed the way the lans are sharded, thx for the info dude. But wait a second, how come when i have the two things mentioned disabled the PCIE slot will work again if i power off and on, it will just stop getting detected on restart? Unless i have the two things enabled...