Return to Level1Techs.com

Xstart broken after Ubuntu 19.04 update

#1

I recently updated my Ubuntu 18.10 os to 19.04. After turning it on today… I ran into the login boot loop. Not happy about that.

  1. What I know for sure is -> no .Xauthority. I did create a .Xauthority file with touch, but still no dice.

  2. I can get to a desktop in Recovery Mode. I don’t understand why this is the case :frowning:

  3. The logs show… god damn there’s a lot here:

http://ix.io/1Lmm

Any help in solving this is appreciate. Bonus: I’ll learn something :slight_smile:

0 Likes

#2

Simple question

Did you rm your home folder?

0 Likes

#3

Nope. Home folder is still there. Dumb question… should I?

0 Likes

#4

Did you notice anything weird?

0 Likes

#5

One other thing I notices was this:

amdgpu: module ABI major version (23) doesn’t match the server’s version (24).

Still trying to determine what’s up.

0 Likes

#6

I’m reading that ubuntu is shipping with out of the box amd gpu drivers. However I think the one I installed for 18.04 is causing some sort of conflict. When I log into recovery mode the driver seems to work without issues.

0 Likes

#7

Can confirm it is a driver issue. The current Vega56 driver isn’t compatible with Ubuntu 19.04. After uninstalling it, I was able to boot into the desktop without issue.

1 Like

#8

W-… why did you install drivers?

Bruh you’re on AMD GPU’s, we don’t download drivers here.

If you installed a driver, updated, and its still there without any new hooks, I’d expect issues.

Glad you got this resolved. Sorry I poofed lol.

And I was asking if you deleted your home folder because thats the only way I really know of for Xauth or xstart to be gone.

In the future, if you use amd? Don’t think about it just install your OS and use it. Thats the goal in linux and amd is the only company thats willing to cooperate.

0 Likes

#9

It looks like the pro driver was installed I think, not required unless you need OpenCL.

0 Likes

#10

not required unless you need OpenCL.

Just gonna leave this here. it’s probably wrong on some ways nowadays, but OpenCL should just be available via an existing mesa package.

I know you’re on ubuntu, and i still need to check the ubuntu repos, but it’s marked as opencl-mesa on the AUR. probably a similar naming scheme on ubuntu universe

https://packages.debian.org/sid/mesa-opencl-icd

not sure if that’s the right package name, but it’s the one i found.

0 Likes

#11

I could be mistaken, I’m not familiar with them since I use the one in the kernel.

0 Likes

#12

if i remember, additional modules are added as seperate packages & ICD loaders (Vulkan, OpenCL, and so on)

For example, you need to install the mesa-vulkan-drivers package to run vulkan and dxvk programs, as it’s not included in the libgl1-mesa-glx package

I’d assume it’s the same for OpenCL (i’m probably wrong)

maybe check if you have libclc, as well.

https://packages.debian.org/source/stretch/libclc

0 Likes