XFX Reference R9 290 MST Issues


Around the time GTA V was released, I bought an XFX Radeon R9 290. Great card. A few months later I bought another to crossfire I liked it so much. Anyway, I had a display setup with 3 screens originally and everything was fine. I wasn’t using DisplayPort or MST at the time and life was good.

So I ended up buying a job lot of faulty displays on eBay and repairing them. There were about 9x 24" 1080p screens in total. Sold 3 of them off and kept the remaining 6 for a pretty kickass display wall I decided on building a bit further down the line.

A bit of background, outlining hardware I have.

I got my MST hub, active adaptors, the works. Made my own power cables to run all of the displays from for ultimate cable management. I had bought 3x dual monitor vertical stands for a 3x2 display setup dirt cheap. Then, I hooked up the 6 monitors.

The problem

So, here’s where the shit hit the fan in a matter of speaking. The displays running over MST just don’t behave. When plugged in, I can get them all working without any issues at all… SOMETIMES. But as soon as I enable Eyefinity or do any other reconfiguration as I sometimes do, like disabling some screens to run the projector, the MST displays perform a disconnect/reconnect loop. All my displays turn off and all I hear from my speakers is the windows hardware plugged in sound and the hardware disconnect sound. Over and over and over. Never ending until I forcefully power the machine off.

Edit: I forgot to mention, to disable Eyefinity in this setup, I have to reinstall my drivers because of the aforementioned issue.

What i have tried

I have attempted the following:

  • Changing the EVGA MST hub I am using a different one from StarTech.
    – Yielded the same results.
  • Made sure I am using VESA compliant cables from StarTech and other reputable brands.
    – Yielded the same results.
  • Using different active adaptors.
    – Yielded the same results.
  • Using different displays (i have access to a wealth of them from a local recycling centre I used to work for)
    – Yielded the same results.
  • Using a different R9 290 just to see if it was just a faulty card.
    – Yielded the same results.
  • Using only the 3x displays connected via MST and disconnecting the rest.
    – Yielded the same results.
  • Installing the latest drivers. I actually created a batch script to go through them systematically and install the first revision and go up and up until i didn’t notice an issue.
    – Problem occurs on every driver revision that can be sourced online and in my own personal backups.

Not a single one of the above worked.

What works

The only thing I have found that yields no problems whatsoever is to use a friends Sapphire 280X. This appears to be a problem with the XFX R9 290’s I own. Now, all I want to know is, is anyone else having the same issue or is this just a coincidence that I have purchased 2 faulty video cards?

Any other input would be much appreciated on the matter. I don’t exactly want to go out and purchase a new card but it looks like this is what i’m going to have to do.

Hmmm the only thing I can think of is flashing the gpu bios…

That was only the first batch, Long before GTAV release date.

Yeah, I’ve heard of this too but I’m not really sure I want to do it considering they lock the cores off for performance binning purposes. If I were to unlock damaged cores on a video card, best case scenario, instability. Worst case, bricking it.

If I could keep it configured as an R9 290 I’d be happy with flashing my card.

Well here is a guide for windows/linux, using HP USB, unetbootin and rufus. If you know what your doing you just need ATIFlash.

And here are the bios(s) for 290s, You can proabably flash any 290 bios but to be safe, make sure the clocks and bios details match up and all should be well. Or re-flash the stock bios.


I honestly don’t think flashing bios will cure anything and the problem is most likey driver or hardware…

My apologies, I did actually try drivers too but forgot to mention. I’ve gone through one of the first driver releases for the card all the way up to the present. Not a single one of them has this issue resolved. I’m thinking it is hardware/firmware related. However, I’m leaning towards hardware. This being said, I’m surprised only a handful of people have reported similar issues to mine on the matter and even then, not quite exactly the same issue.

Though I suppose a lot of people don’t have 6 monitors laying around and an MST hub that costs more than some mid range graphics cards to test this kind of thing on.

underclock the ram, It probably wont help but worth a try esp. with Elpida.

I had a 290 back in the day, Had underclock to avoid black screen

Black screen isn’t your issue since yours goes off but still.

Thanks, gonna try setting it from 1250 MHz to 1000 MHz. If that doesn’t go well, I’ll try setting it as low as it’ll go just for shits and giggles.

Edit: The drivers don’t like it. Won’t let me go below 1250 MHz

unlock the overclocking in afterburner or whatever, don’t use the AMD thing. yes?

Its been a long while for me

Yeah, I was using the AMD software. It used to let you do stuff like this when it was catalyst control center. Damn, I miss those days.

Gonna try afterburner.

Try different power supply.

A different power supply was tested. Same issue. I have gotten an oscilloscope to the power rails also and there is negligible ripple at a good power draw. It falls well into the ATX specification.

Also, underclocking the VRAM did nothing. If anything it just made it worse.

I must stress though, this is only an issue with DisplayPort devices connected with MST. In any other situation, there is no problem. Albeit I can’t actually attach all displays to the machine in that case.

One thing i want to try (but haven’t had chance to yet) is to try a different R9 290. One from a different brand like Sapphire for example. I am in the process or sourcing one from a friend to test with.

Another thought, I’ll swap the R9 290 out into a separate build and see if it still has problems there.

1 Like


Got another R9 290 to use. I’ve since removed all MST devices and run the individual cables to my video card directly. The same thing happens.

This no longer seems to be an issue with MST but an issue with 6 monitor display setups on this card.

However, it does differ slightly when they are all connected. It only happens in this setup when I have all 6 monitors connected and I turn on Eyefinity (this likely because I have 3 monitors on the top card and 3 in the bottom). all my screens go off, I hear the all too familiar disconnect/reconnect loop and I don’t hear the end of it until I disable all displays connected to one of the video cards. Then it goes back to just the normal extending to the other displays. Problem is I still have to uninstall my video card drivers and reboot twice in order to use all 6 monitors again. This is likely because it makes a monitor profile for them all and tells the drivers to run in Eyefinity the next time it sees all 6 displays again.

Since there are no options for this and I’ve rooted around in the registry trying to find something I can delete for it but so far, no luck, I cannot stop this from happening other than not using Eyefinity at all.

This appears to be one of those issues that will never get fixed because so little people have it. Could be a driver issue, could be a card issue, who knows.

All i know is it’s borked as hell and i don’t know who to trust anymore for getting a video card that’ll run a setup like this. That and newer cards are super expensive probably down to miners.

Ummm, judging by what I have read here, all the arrows are pointing toward the R9 290 driver. Specifically the 290 driver… So if you are not squeamish you could flash your 290 with a 290X bios.