Return to Level1Techs.com

X570 shuts down instead of sleep

As I suspect this to be Gigabyte issue, I post this to the motherboard forum, however admins please moderate as needed.

I have X570 Aorus Pro, Ryzen 3950x. This issue started after upgrading my processor to 3000 series.

So if I choose Sleep from Start menu, the computer shuts down instead of sleep. It is peculiar behavior, because first it seems it goes to sleep normally. But if I then press a key or mouse button to wake it up, it the fans spin up and it is same as total shutdown.

My issue seems to be exactly same as this:

https://www.tenforums.com/general-support/138070-x570-ryzen-3600-shuts-down-instead-sleep.html

What do you guys think?

What windows version? What bios version?

1 Like

BIOS is latest F12e
Windows is Version 1909 OS Build 18363.720

I had the same issue and was able to fix it by disabling “C6 deep sleep states” in the BIOS settings. I’m on an AsRock x570 with Ryzen 3000.

This prob isn’t your issue, but thought it was worth mentioning:

On a side note, I’ve seen similar behavior after installing 4x 8gb 3200/CL16 DIMMs. It would go to sleep, but after trying to wake the PC up it would just reboot. Slowing the memory down a tad fixed the issue.

1 Like

Oh!! Thanks for this. I will try that.

I am using 4x 16 sticks, so that could well be my issue.

Uh-oh, I wonder where can I turn this off in Gigabyte Aorus BIOS?

I would look in your motherboard manual, there should be a chapter on your motherboards BIOS settings. Since I only have an Asrock x570 Tachi motherboard, I won’t be of any further help.

@Shadowbane’s solution would be best but what I usually do is just poke around in the BIOS settings till I find whatever I’m looking for. It’s not buried super deep on AsRock’s setup IIRC

I download the manual for Ryankocool’s motherboard, I think the setting he is looking for can be found by getting inside his UEFI, then choosing Tweaker, choosing Advance CPU Settings, setting Power Supply Idle Control to Typical Current Idle. What this setting is supposed to do is shut off al C6 states. @nyankocool I would contact Gigabyte tell them your problem and the possible solution, and see if you apply the fix if it will hurt your Motherboard. I give this caution because, in my opinion, the AMD Zen platform is very finicky. In fact, my next desktop platform is going to be Intel.

1 Like

Thank you for clarifying this, indeed, reading the manual more carefully is a nice idea for myself…

I tried did make this change in BIOS but it didn’t solve the issue. I will definitely let Gigabyte to know about this.

So you were able to log into Windows after making the change, I am surprised Windows loaded up. There must be other settings in the UEFI that need to be changed, as to what those changes are, I don’t have a clue. The next step is to contact Gigabyte and see if they can help you.

1 Like

Yes the Windows did load with Typical Current Idle and saw no issue with it.
Sending email now to Gigabyte.

This isn’t a show stopper really, I just shutdown my computer instead of sleep, however would be a nice comfort to have, a sleep mode…

1 Like

I got reply from Gigabyte.
They just said

For support and service in Japan, please contact our authorized distributors in Japan.
http://www.gigabyte.jp/Support/Warranty

Well that makes sense, but I do not believe that they will support me in this case as the product is not broken.

@nyankocool I forgot to ask why do you want to use sleep mode, Why not just shut down desktop when done?

1 Like

yes certainly, that’s good question… even after sleep I need to still login to Windows so makes little to no difference.