Return to

X570 Aorus Xtreme - Samsung 970 EVO NVMe Missing

I’ve been helping a friend who’s finally gotten around to build a new computer, which involves this motherboard along with the AMD Ryzen 3800X. He’s got a 2TB Samsung 970 EVO Plus NVMe for this machine as well, but it will not show up in the BIOS nor will the Windows 10 installation detect it either.

This drive was tested in slot “M2A” which ties directly to the CPU and slot “M2B” which ties off the chipset.

The BIOS was also updated to version F10, downloaded from their website and installed via Q-Flash within the BIOS. It originally came with version F2 installed.

As mentioned by @Wendell in the thread for the Aorus Master I figured that this one would be requiring us to set the PCI-E mode from auto to Gen3.

That nor disabling CSM seemed to have fixed the problem. Nor did setting the BCLK to 100.00 like one place suggested seemed to have worked.

The bad news is this friend lives out of state (Nor does he have an account here, but this can change easily enough.), so he doesn’t have access to other components like I do in order to test everything thoroughly. Such as another machine to test the NVMe in or another NVMe to simply test in the new machine. So I’m hoping anyone here may have an idea on what to try next.

Full parts list of the components he has that’s been sent to me:
⦁ [CPU] Ryzen 7 3800x 8-Core 3.9GHz
⦁ [Motherboard] Gigabyte X570 Aorus Extreme
⦁ [Cooler] Noctua NH-D15
⦁ [RAM] G.SKILL Trident Z Neo Series 32GB (4 x 8GB)
⦁ [GPU] MSI GeForce RTX 2080 SUPER
⦁ [Drive] Samsung 970 EVO Plus Series - 2TB PCIe NVMe - M.2 SSD
⦁ [PSU] Corsair RM750x
⦁ [Case] Lian Li Lancool One Digital Black

Did you work out what the issue was?

Not yet, we’re waiting on an external NVMe USB-C enclosure to arrive so I can have him test the drive in another machine to ensure if it’s a DOA or not.

Since I use the same enclosure for my Intel 660P, I know it should work for this test.

Plus since he works evening shifts, he’s been saving the project for the weekend.

Why not just use that for testing?

1 Like

I would, but unfortunately he lives out of state, a good few states away at that. Thus making troubleshooting more difficult.

Oh, of course. I think the

threw me off. :upside_down_face:

My apologies, I think when I responded to Wendell when I was about to be on my way to a job that needed to get done. I think I should have wrote that more clearly. :sweat_smile:

Since he’s checked the tracking, it shows it’ll arrive Monday for him. I just want to determine whether the NVMe is dead or not, and if it isn’t then I may have him try updating the firmware on it. I’ll definitely report back the results.

1 Like

Alright, so based off what he’s tested with that USB-C NVMe enclosure, the Samsung drive appears dead.

Since he’s waited beyond the return window for the components, he’ll have to go through the RMA process.

Should I go ahead and have this thread marked as solved, or wait for when he gets the replacement in and verified to be working first? :thinking:

How’d it go? I have the X570 Aorus Xtreme so I’m curious what happened in the end.

Also what external NVMe USB-C enclosure are you using? I haven’t seen a NVMe to USB enclosure before (lots of SATA M.2 though).

Well, I’m still waiting on him to actually get his SSD warrantied. He says he can’t get a hold of anyone at Samsung.

Does anyone have any ideas?

As for the external enclosure:

USB-C, and compatible with USB 3.0, and even USB 2.0 from my testing.

You might consider buying a relatively inexpensive, small M.2 SSD to get past the “roadblock”. That would allow you to continue testing and hopefully get the machine operating.

Thanks for the link!

If you don’t mind, I would like to hear what eventually happens.

@Caped_Kibitzer 's suggestion seems reasonable (though costs more).

Alright, so he bought a 1TB Samsung NVMe drive and installed it. It works, so this proves the motherboard’s fine.

However he’s still having trouble getting a hold of someone for warranty services. I haven’t dealt with Samsung in terms of getting an RMA done, and I couldn’t find anything online either. :thinking:

1 Like

Here we are a year later and AMD and Gigabyte can’t get their act together. I just got a Aorus X570 Master 1.1 and 2 Samsung Evo 970+ NVME and using F20 July BIOS and July AMD Raid drivers and white, it all built fine all of a sudden RAIDExpert2 screams a drive failed. I switch slots and it follows drive. I exchange bad drive and rebuild Array and a few hours later the Array went critical again on new drive. I move drive around rebuild array and again fails. Both failure on both drives say controller failure, yet the drive shows online, I rebuild the array and happens again. 2 bad NVME drives in a row? Possible, likely? No. I clone the drives to EVO 960 SATA Array and no issues. I left AMD years ago because their RAID sucked, seems no change. I should have gone Camp Blue as their RAID and BIOS is just far more mature. Building a good economical COU without good chipset software and BIOS is a waste.

Currently building my system. Same hardware as original poster: Aorus x570 rev 1.0 and Samsung 970 Evo 1 tb. Unable to edit in the BIOS with the EVO in. No problem (but evidently cannot boot) with the EVO out. Tried all 3 slots with the same result. Anybody got something on this problem?

If not I’ll try to contact Samsung…:frowning: