X370 taichi ignores clock modifier

R7 1700x
X370 taichi
some stupid ram that has the same serial as b-die but is actually M-die hynix or something FML

Spent the night overclocking, Got CPU to 4GHz at 1.3v so I moved on to ram, just to test my luck I tried 3.2 Ghz and it wasn’t having any of that.

Try it at 2800 MHz on stock timings 16-18-18-36 and it boots just fine. But now, even though when I head back to the eufi my settings are still there, I’m running at 3.5 Ghz on the CPU.

what heck? Gonna try resetting the eufi. then I’ll be back.

It worked, no ram OC yet, but my CPU clocks are back to where they should be. I’ll try it now.

Welp, here’s a tip for anyone with the taichi, late to the party as I am. If you can post because of ram speeds you probably need to reset your eufi anyway because the clock modifier settings will not tick. All my overclocks seem gold now.

1 Like

The 1550Mhz or 3500Mhz 'Stuck Clock" is a Firmware bug.

It hopefully will be fixed soon.

When I’ve run across CPU overclocks failing to stick, it was usually possible fix it by reflashing BIOS

On X370 motherboards that is