Return to Level1Techs.com

WoW stuttering on Kubuntu but not on manjaro?


#1

So I am still playing WoW … for some reason and I am alternating between two systems doing so. A manjaro KDE running Ryzen7 1700 OC’ed to 3.8GHz on all cores, R9 Fury and SATA SSD vs my Kubuntu 2700X stock, Vega64 and NVME storage. The silly thing is that my objectively slower system runs fine and the 2700X+Vega64 machine stutters pretty heavily whenever something new enters the scene / something has to be loaded in.

Things I have done so far:

  • CPU governor -> performance via sysfsutils (also tried cpufrequtils) and CPU is basically boosting all the time now.
  • Changing graphical and advanced settings ingame.
  • Manually setting CPU speed and voltage in the UEFI.
  • Turning off C-states and Cool&Quiet in UEFI.
  • Setting pcie_aspm=off on boot via grub.
  • Moving the whole game folder to another drive.

Nothing changed.

I am on Kubuntu 18.04, kernel 4.20.14, lutris 0.5.0.1.

Question is: anything more I can do?
Or is it possible that manjaro is just the better fit for this specific problem?


#2

i got it working good on Fedora 28 and 29. then they(activizionblizzard) made dick moves and i canceled sub.
Not going to support that shit anymore.


#3

have you tested what happens when you change video cards ?


#4

No. I doubt that this is a GPU issue or even a GPU driver issue. I have no problems running Doom 2016 on ultra everything with no stuttering at stupid speeds.


I get that, doesn’t help me tho… Let’s keep that WoW / ActiBlizz discussion out of this please.


#5

Well it seems like you tried a lot of things on the software side of things, that’s why I thought if you swap the GPU’s you will be able to see if the vega card performs better under manjaro.


#6

Since those two machines are not in the same place that isn’t an option. If nothing else works I am going to switch to manjaro on my vega system anyway. But that is the last resort, the thing I am trying to avoid.

Also as mentioned, it is this game specifically. In general the GPU is running insanely well. I just played a bit of Doom again at ultra and I am getting no stutter at all. (up to 200fps in 1080p and around 120-140 in 1440p… what a game! :smiley: )


#7

Wish you luck. I don’t play games under linux so I don’t have any experience. Share details if you fix it or switch to manjaro.


#8

That’s pinpointing it down to a Mesa issue. But it could be you’ve left composition on. Turn composition off with Shift+Alt+F12.

Linux also ignores C-state settings from BIOS so you have to add C-state options (like turning it off) as a kernel command line in GRUB.


#9

Have you tried the dx12 dxvk wrappers yet?
i have heard mostly good about it.


#10

I’ve known this for a while. That said, I’ve never bothered to ask why this is the case.

So… Do you know the rationale behind that?


#12

@sgtawesomesauce About all I can find on that. From IBM.
To determine if the kernel has the ‘intel_idle’ driver included, check for the following directory:

/sys/module/intel_idle

If it exists, then the kernel includes the kernel driver and will ignore the BIOS/UEFI settings for C-States.

Read that Here. But it instantly redirects me from that page when I load it so just stopped loading it after hitting back. All they really say is “Because latency”


#13

This looks to be the one! Thank you. :+1:

[EDIT] No, sorry. It’s still there. Your suggestion absolutely helped with fps, so still a big thank you! :slightly_smiling_face: But the stutter on loading in new stuff is still there.


#14

Does typing the following make a positive difference?

/console worldPreloadNonCritical 0

If so, add this to your Config.wtf and then restart your system to flush the cache.

SET worldPreloadNonCritical “0”

If the computers are in different locations, stuttering could actually be a sync issue with your monitor (triggered by a dip into low-FPS territory whilst objects load). Turn v-sync on, fix the monitor refresh rate at something sane (60Hz, or maybe 30% less than the max FPS your system can handle), and limit the game FPS to match. (Last time I played WoW FPS was automatically capped, but now it might have a “StupidlyHighFPS? Yes, please!” setting.)

I’m not sure how the WoW client implements “triple-buffering” but you could also have a bit of a play with that if you haven’t already.

…waiting for Classic.


#15

FPS are perfectly fine and it isn’t a graphical setting, I am pretty sure of that. I know how that would feel and this is different. The game just comes to a halt for a second. Also it happens whenever something new is loaded in OR when I hover through my bags and the game is loading the tooltips for the first time.


Nope, unfortunately not. Also tried 1 (because… why not?) and it didn’t do anything either.
(Yes, I did a /reload each time. :wink: )


#16

Do you literally mean one whole second?!? If so, then you’re right — that’s not a v-sync stutter.

On the off-chance that it’s a culling issue, have you tried dropping you MaxDrawDistance (or whatever it’s called) to something minimal?


#17

Yes, I do. When I hover the mouse over a couple items the frame will freeze for literally a second or so.

Yup. And also my bags are not full of wide landscapes. :wink:


#18

Stutters when opening bags? I would say that’s an add-on problem then. An ‘out-of-date’ Auctioneer did that to me once — Lua was choking on errors behind the scenes. Temporarily disable all add-ons and see if the problem persists.

There’s also the possibility that something in your WoW cache has become corrupted. Delete your WoW cache, let it rebuild, and see if the problem persists.


#19

It’s bagnon. I tried disabling informant before but didn’t try the bag addon itself… Stupid me.
That fixed it pretty much. The other environmental loading stuff is down to a minimum as well. Everything beyond this is down to WoW being WoW.

Again, thank you @level1 and @FurryJackman! You helped me a lot. :smiley:

FIXED FOREVER!


#20

MHWD is usually better at hardware detection than Ubuntus DRM implementation. While it may appear as though it’s not an issue with the GPU driver and configuration, it might very well be.

I know that Manjaro performed better in most titles for me when I switched over from Linux Mint. Never cared to figure out why though.

I hope you get this sorted out. GPU drivers can often be a pain.

One thing I will say is that MHWD is one of the best things ever lol. Only thing I dislike about it is Prime isn’t an option so you’ve got to rely on bumblebee unless you want to spend 2-3 hours like me troubleshooting it.


#21

Oh, now that i think about it, i got the very same problem with bagnon addon. Used it only shortly and uninstalled it because the performance hit it made.
ElvUi works well i can tell you. it has most of the addons you need and has minor performance hit. Also it gives you good tools to move annoying features to the sides where they don’t bother your gaming.

If you get some auction addon, just make a favor to yourself and apply it for your bank alt only. no need to bloat you main with that stuff.