Return to Level1Techs.com

WolfTech's ASUS Linux Journey

As many of you have probably already seen, I purchased a brand new ASUS TUF505DU-EB74 from Amazon on Monday, received yesterday, and openSUSE installed last night.

So far everything has been going pretty well, and I realized I wanted to make sure I had my post started to document my journey. I began by letting the initial Windows 10 OOBE run so I could confirm all the hardware was working (including the 120hz display), and no odd issues or crashes.

Sadly there has been one downside so far, though it’s completely minor in the grand scheme of things. The keyboard (RGB woohoo?) cannot be controlled or set statically without the Aura Core software running. This just means that while running Linux I will forever have a rainbow, but again that is a minor downside.

For those who are interested the specs are as follows:

  • AMD Ryzen 7 R7-3750H
  • GeForce GTX 1660 Ti
  • 16GB DDR4
  • 256GB PCIe SSD
  • 1TB HDD (Toshiba MQ04ABF100 according to GNOME Disks, measly 5400 RPM)

The adventure thus far:

I originally tried installing from an openSUSE Tumbleweed network image but found very quickly that the wireless card (RTL8822CE 802.11ac) does not like to hold its IP via DHCP. I swapped over to the full DVD ISO, threw it on my laptop using Windows 10 (prior to having a clean slate) and performed a minimal “X Server” type of installation.

For some odd reason I could not get the WiFi network to re-connect. Everything worked, I proceeded through YaST and it said everything would run, but nmcli refused to agree with me/YaST that the ESSID existed. All that to say, I restarted the installation process, setup a “typical” GNOME laptop setup and confirmed that everything was working as I expected.

The next hour or so (nearing midnight by that time) I attempted to install a program called OpenRGB which led to a few things that gave me issues, though now that I know, are easy fixes. (ie. Somehow during my tired state I had forgotten how to enable qmake on the system…)

OpenRGB installed without a hitch, but it didn’t see my keyboard which told me it was simply incompatible (again no worries, just means I only use the backlight when I want rainbows everywhere).

That leads me to now, just finished not working too long ago, and have been working on trying to install Windows 10 inside of Virtual Manager/QEMU in order to setup RDP to hopefully run Xbox Game Streaming to game some. I could dual-boot, but I have made the resolution that until I run into every wall possible, I won’t switch to Windows, so let the fun begin! Funny enough I forgot to turn on the virtualization aspect on my processor in the BIOS so I am in the process of starting the W10 installation again.

If anyone has any requests for what I talk about/review, or any suggestions for what to try let me know! This is my first time writing about my experience, so there’s bound to be a lot of mumbo jumbo above. Thanks for reading and I’ll keep updating this post as I finish my projects!

Almost forgot, also working on installing awesomeWM as we speak and will switch to that before re-installing the W10 VM.