Wireless adapter issues

so I have this USB wifi adapter that has worked fine for quite a while on other computers, but it will not work well on my main desktop. speeds go from 3mbps on a different PC to .2mbps on my desktop. It's not signal quality, as it works fine when booted into Linux, it's not the adapter because it works in another PC, and on the desktop in linux, I have tried using every driver under the sun, including the one that came on a disk with the adapter, which is the one that is on the other machine.

I don't know what else to do. I tried using different USB ports, and it made a slight difference for about a day, and then it tanked again, and now, no matter what USB port I plug it into, It doesn't help.

here's a link to the adapter in question. http://www.amazon.co...ds=wifi adapter

also, Ethernet isn't an option, so please don't suggest it. ;)

Update: still having issues. anyone else have a suggestion? I've updated the BIOS, and it didn't help. it's not interference since the adapter works in the same exact spot under linux, and I get a perfect signal from my phone and from my laptop in the same spot.

Powerline won't work in my case because the location of the router and the location of my PC are on different panels outside. (it's complicated)

anyone have a suggestion?

Can I get some more details please - what OS is it NOT working in? What speed is the adapter rated for? What speed is your router capable of? Is everything set to auto?

everything is set to default. the OS it is NOT working in is Windows. router is capable of 72mbps, adapter is capable of 150mbps. my internet (WAN) speed is 3mbps/0.6mbps.

the issue is that my ping is erratic with spikes up to 1000ms, and download speeds are slowed to a crawl even with no other network load.

signal strength is not the issue since it work in the exact same spot while booted into linux.

Linux, Same PC WORKS
Linux different PC WORKS
Windows different PC WORKS
windows same PC NOT working

thanks for helping, I'm getting desperate at this point.

you've answered your own question really:

  • its a windows issue
    • drivers and/or
    • corrupt files and/or
    • software conflict somewhere
  • remedies
    • clean windows from top to bottom
    • reinstall windows
    • dont use windows

Uninstall the driver, reboot

Go into power settings and prevent windows from turning the device off to save power

Go into network adapter and settings -right click adapter - properties - configure and force 20/40mhz co existance, turn off any power saving measures, make sure no channels are disabled and disable sharing

I have tried reinstalling windows, and it doesn't help. I also need to use windows for my school, so just not using it isn't an option. i'll try reinstalling the driver one more time, but I don't have high hopes.

remove the device entriely in device manager, reboot

tried it. didn't work. :/

I also made sure all settings were like they were supposed to be, and power saving is off.

have you tried boosting the TX power level in properties?

1 Like

I have not. how would I do that?

what version of windows are you on?

8.1. I refuse to upgrade to 10.

To get to it:

Control panel

Network and Internet

Network and sharing Center

Click on manage wireless settings, on the left hand side of the screen

HIghlight your internet connection on the list that appears

click adapter properties, above the list of connections

Click "configure" (under where it says connect using: realtek (or whatever you have))

Go to the advanced tab

TX power level is listed in the box, click on it to change value.

there is no TX power level listed. :/

Message me so we dont pollute
the Feed


What kind of encryption is set - TKIP or AES? - Check on your PC

  1. control center
  2. network and connection center
  3. active connections - click on your wifi connection
  4. wireless properties
  5. security - from there you will see either AES or TKIP selected.

Ideally you want AES (in any case) so configure your AP and then reconfig the client devices. Head to your router/AP web portal or or etc
I have seen instances where if TKIP (or both TKIP & AES) is set on the AP clients will connect via TKIP and be limited to 'g' standard speeds. Quite uncommon but depends on the AP.

  • just right click your connection under the 'Network Connections' tab (from above post to check TXpwr) and head to 'Properties' - whilst client for Windows is already highlighted just click on Configure and view all the info there under 'Advanced'. By default (even when power settings are changed) the Transmit power should be set to 5.
1 Like

my adaper settings were on AES only by default, but my AP settings allowed both, so I disabled TKIP. I'll check to see if that worked and get back to you.

it didn't help anything. :/

I also looked for TXpwr and there is nothing even close to that under advanced, or power management settings.

@ProSonicLive You would not be polluting anything. It may actually help some others too as well.

Well then its actually rather simple. If it was not windows and it reported your signal quality was okay and you have tried everything else. The software is lying to you. Something is interfering with the PC's line of sight to the router. Where is this computer located in relation to other PC's and the router. I know everyone here is going to say "its not a signal issue" but in fact software is stupid it actually could be. How far is it from the router. What standard (802.11x) is the router using and the adapter? I assume 802.11n (20 Mhz wide channel single channel non bonded) so adapter goes up to 150 mbps?

Why did you say the router supports 72 mbps thats a strange rate what standard is it using?

PLEASE post the model number of the router and the adapter. The link does not DNS probe resolve.

I first really need to know the hardware that is being used before I can begin to help.

1 Like