Return to Level1Techs.com

Windows won't install cause of missing driver w/ C7HWIFI-MoBo [solved]

helpdesk

#1

I had a bad day and after creating this topic I will go to bed :disappointed_relieved:
You guys are my last hope to get my system running with Windows, so I can update Firmware of the GPUs and get writ of HDMI cabels.

The MoBo is an Asus Crosshair 7 Hero Wifi.

My Problem:
When trying to install Windows10 on my virgin system it asks for Drivers, but I dont know which one. I tried to download all related drivers from the Asus Homepage and I even tried the CD in the box of the mobo. Nothing seems to work and I can’t get past prepairing the installation.

My Windows7 CD don’t like USB at all, so this isn’t an option.
Instead I used three different Win10 images (two new and one old iso) and created bootable USB devices. All complain about the same.

Also I updated the bios to 1201 (newest version form the Asus-HP I think).

I hope it has nothing to do with the NVMe and I have to unplug it.
Cause the Samsung 970 NVMe is buried under the dark rock air cooler.
I looked in the BIOS to deactivate the NVMe but I didn’t find it.

Both GPUs (MSI 1080TI and EVGA Titan X) are so big I can’t imaging getting them unplugged without breaking something. With other words: I dont know how to reach the PCIe lock-switches.

My goal was … is to install Windows10 on one of my two Samsung EVO SSDs, so I can install new Firmware onto the GPUs and hopefully can use DP at bootup.
There are many Guides on how to fix the DP on Bootup problem but none seems to work on new Acer Predators Monitors.

And there are so many hick ups when trying to install Windows…

  • No Display Port at boot
  • Windows don’t like vfat > 3GiB when installing Win10
  • missing drivers
  • weird error codes that were missleading so I run memtest and Gentoo just to be sure all works

Can you give me some hints or advice ?
I know I should unplug all unnecessary hardware and then try it again. I probably will do this tomorrow. I have a second PC in the same room, maybe I should squese the GPUs in there to update Firmware and be done with it.

Never thought Windows will complain that much, it cost me a whole day already. Sorry for biatching but my Anger-manager isn’t here right now :exploding_head:

HALP \o/


#2

Allow me to share what I have been told here:

Install Linux and use a VM for Windows.

Personally, I will never use Win 10 but in a world where that’s all you have there is not much else to do. I’m sure in time Windows will work itself out. You likely need updates.


#3

I’ve had that same issue installing on the non-wifi C7H. The issue was either a badly formatted drive or writing the iso failed.
Otherwise…

First make sure those SSD’s are properly formatted and then
I recommend you check your UEFI to make sure those two Samsung SSDs aren’t in RAID, because for that you will need the drivers from ASUS’s website.

Wendell goes through that process in this video.


#4

Never had Windows 10 ask for drivers during installation.

What is the specific error message? A picture would be great.

Ensure your drives aren’t in RAID. You shouldn’t need any RAID drivers as you’re not setting up an array. Just installing to a single SSD

My bet is simply your ISO is not good

Grab the media creation tool here

https://www.microsoft.com/en-us/software-download/windows10

and a flash drive at least 8GB. Create the media and then go from there.

Use your USB 2.0 ports btw


#5

Yeah, thats the goal, but how can I install Firmware onto GPUs so I can use DP instead of HDMI. atm I cant use 1440p.

I have two new ISOs from Microsoft-HP and one old one, and those work on both of my systems.
To be clear on the USB devices …
The images are called Win10_1809Oct_English_x64.iso and Win10_1809Oct_German_x64.iso. Then I have this old ISO from a few month back called Win10_1809_German_x64.iso. After partitioning and farmating with ntfs the devices look like this …

GNU Parted 3.2
/dev/sdc wird verwendet
Willkommen zu GNU Parted! Rufen Sie »help« auf, um eine Liste der verfügbaren Befehle zu erhalten.
(parted) print
Modell:  USB DISK (scsi)
Festplatte  /dev/sdc:  8054MB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: gpt
Disk-Flags:
Nummer  Anfang  Ende    Größe   Dateisystem  Name   Flags
 1      1049kB  8053MB  8052MB  ntfs         Win10  boot, esp

Then I copied all files from an Iso into this drive.

mount -o loop Win10_1809_German_x64.iso Win10
cp -av Win10/* /mnt

ls -l /mnt/sources/install.wim
-rwxrwxrwx 1 root root 3,9G 15. Sep 20:49 /mnt/sources/install.wim

ls -l Win10/sources/install.wim
-r-xr-xr-x 1 nobody nobody 3,9G 15. Sep 20:49 Win10/sources/install.wim

I have no error when using those devices and they work on my both systems.

A popup says missing media driver, nothing else. Then I get an empty window with “select driver” on the top and three buttons on the bottom; browse, rescan, and the third button (next) is grayed out.

I used my rescueCD to partitioning and formatting all drives.
/dev/sda and sdb have now a GPT Table and one huge NTFS partition each.
/dev/nvme0n1 has also a GPT Table and one huge EXT4 partition on it.

BIOS settings:
NVMe Raid mode is disabled.
SATA mode is AHCI.

Launch CSM is enabled.
Boot device control is stet to UEFI and legacy OPROM.
Boot from network is disabled.
Boot from storage/PCIe are both set to legacy only.

These are the all the default settings and I didn’t change it.
The only thing I did was activate D.O.C.P. to get the 3200MHz 14-14-14-34-48 with the GSkills (F4-3200C14-16GTZ) to work.

I tried to set all CSM to UEFI only, also this didn’t work.

One other thing: The timer in the BIOS is slightly off and I dont know how to change it. The system lives about 12 hours in the past.


#6

JFF I started Windows on my second computer and downloaded the installation tool from the Microsoft-HP.
Then I created a new USB Device, and this time I didn’t need extra drivers to get Windows installed.

I think the problem was that MS-ISOs didn’t have any drivers at all, and the MediaCreationTool1809.exe is what I needed to get Windows installed.

Thanks all for the help! :smile:

Why the heck does Microsoft offer ISOs when you can’t use them to install Windoof onto a virgin computer. Anyway, I made it.


#7

Afaik the only legitimate supported way is to use the media creation tool.

I really don’t think it was an issue with drivers more just an improperly created iso

Glad it’s working for ya


#8

Telling someone to “just install X” when they are not posting in that category is extremely unhelpful.


split this topic #9

2 posts were merged into an existing topic: The Lounge - 2019/02 February [I Didn’t Vote For This Edition]


closed #11

#12

Topic was marked as solved.

If you ever want the thread reopened OP, let one of the leaders or mods know. They’ll open it for you.