Return to Level1Techs.com

Windows VM Audio Stopped Working

I wasn’t completely sure where to post this since it’s an issue with running Windows in a VM (Linux host), but as far as I can tell this is a Windows issue…

So I’ve been running Windows 10 in a VM for a couple years now and in general it’s been working fine. However after doing some Windows updates recently my audio has completely stopped working. While device manager and everything else I can check claim the audio device is working properly, any attempt to actually play audio on it will completely hang. I have tried using a USB audio device and did manage to get that to work (though it needed a driver update) but the system audio is completely unusable.

I’m running the VM under QEMU/KVM and the audio device in question was originally set to “HDA (ICH6)” though I’ve also tried “HDA (ICH9)”. It shows up in Windows’s Device Manager as just “High Definition Audio Device”. It’s the generic driver from Microsoft, version 10.0.18362.1 and it says it’s the latest although it’s dated 3/18/2019. Again, it used to work fine until Windows was updated. I have tried updating the driver and uninstalling and then reinstalling the driver but nothing seems to help.

Everything within Windows that I know to check seems to think the device is working fine but when I actually try to play audio whatever application is doing it will just hang and have to be killed. So it’s not just that I can’t hear the audio or something.

I’m kind of at a loss what to do at this point so any suggestions would be appreciated.

Hmm, what QEMU machine version are you running? I encountered something similar when I upgraded to QEMU 4.0 and the new q35 model broke me. I had to set it back to 3.1 to get it to work.

I believe you are having the same problem that I had. it is because of 1903 update from windows.

Currently using a usb card and not tested new updates since then, but checking new posts it seem some people managed to get work with scream in this post.

So you probably will have to do one theses things:

  • Use scream
  • Use a usb/pci sound card
  • downgrade windows 10

Thanks nakamura, that looks like exactly my problem. For now I’ve downgraded Windows but scream looks interesting so I might have to check that out in the future.