Windows Update Failure 0x80070003

I have an older laptop that I keep around as a Plex server, it has been updated from windows 8.0 to Windows 10 Home 64 Bit. Once a month however, when the cumulative updates come out Windows Update will always fail. I have done a complete reinstall twice now using the latest image provided by Microsoft media creator. Each time I reinstall it will allow me to get the latest updates no issue till the next ones come out the following month. Any thoughts on what could be causing the issue? Below is the laptop information and error code from Windows Update.

Laptop Specs:
Processor: I3-3217U 1.80Ghz
Ram: 16 GB
Hard Drive: Seagate 500 GB 5400 rpm.

Error Code: Some update files are missing or have problems. We’ll try to download the update again later. Error code: (0x80070003)

Other notes: Not sure if it is related but every time Windows 10 is reinstalled only balanced power plan comes enabled I have to add high performance via a command prompt.

I’m curious why you picked Windows 10 as a server instead of something like a Debian/Ubuntu/Fedora (or any other Linux distro) which may provide you with more OS stability and a better networking stack.

As I am not Linux savvy and putting Windows 10 on it allowed me to put some work applications on it that are Windows only. It was only recently converted over to a Plex sever. It is also a fall back laptop for when my dad needs it in emergency and he is not Linux savvy either.

Updates on the trouble shooting steps.

The laptop itself even with ethernet cable plugged it experiences the issue. It will download and attempt a install and gets to the point where it says to restart and then it fails rolls back the update and will attempt a few days later to install again in a cycle. I have also attempted to download the update itself from their catalog and the install also fails then.

The hard drive passes the S.M.A.R.T. check. I am wondering if the laptop is so under powered that it times out during the install portion during reboot?

Have you tried to manually download the files directly from the MS website? Last i recalled (at least from Win7 days), you could individually download the specific update as a standalone executable like a KB######.exe or something.

Also I would dare say that these days, you dont need to be particularly techsavvy to use Linux, even for your not-techsavvy father. Ubuntu has come a long way to make things actually - and remarkably - easier than Windows. For the low low price of learning an easy new OS, you get your sanity back. You could probably load MS Edge and use online Office 365 or something.

1 Like

It’s stuck for me too, but I don’t care too much about it to be honest. There will be a fix somehow later. Also seeing this post reassures me that my Windows installation is still working correctly.

This might be worth trying:

Under C:\Windows\

Rename the following:
SoftwareDistribution → SoftwareDistribution.bak
WindowsUpdate.log → WindowsUpdate.log.bak

Under C:\Windows\system32\

Rename “Catroot2” → “Catroot2.bak”

Reboot the PC and retry the updates.
What you are effectively doing is clearing your updates download cache and restarting the updates from 0.

have you manually turned off some services ?.. sometimes windows will run and update for an application but will need to start a service to do it. but if that service or a dependency is disabled. windows wont be able to start it so will not be able to run the update.
also if your antivirus/antimalware*/spyware* stops windows telemetry and other dial home services by adjusting group policys and reg entries. you may have to revers them (or disable the antivirus) while doing your update.
(*spybot antibeacon,avira)

1 Like

You can always just download the media creation tool and run the upgrade that way.

I tried doing the upgrade through media creation but it also fails. Also downloading from the catalog itself and that fails as well.

After messing with some intel drivers one of the cumulative did install but there is one that continues to fail with the same error message of missing files.

So it appears its not liking one of the older drivers. Wish I knew which one.

if its saying missing files there might be a log of it in event viewer.

In my case there’s no missing files, but it still complains for some reason. i ran the Windows Update error scanning tool thingy mcgee and it says just to re-try installing.

Nothing shows up in event viewer. When doing their image scan it says all the files are there. I will keep messing with the drivers to see if I can’t narrow it down.

It’s possible you’re missing some updates. Which version of Win10 do you have? I’d suggest that if you have picked only critical updates, you do optional ones too. I used to do critical only but eventually it bites you in the ass as eventually, a critical update depends on an optional one you skipped.

It might be best if you download an ISO of 20h2 and do an upgrade to build 20h2 from that, then keep up to date with the cumulative updates.

Whilst Microsoft said “Windows 10 is the final version of Windows” or such, there’s actually many different variants of Windows 10 and there’s almost as much difference between some of them as there is between Windows vista and Windows 8.

Have you done anything to it like trying to block telemetry, etc. using third party tools/hacks or manually messing with it via hosts file or blocking its network access via firewall rules?

I’m not suggesting that’s a bad idea (you do you), but it is possible it can’t download or validate a digital cert or something if you’re interfering with its connectivity to the internet.

1 Like

I’ve got some VERY under-resourced virtual machines that still manage to run Windows update OK. An i3 with 16 GB should not have any problems.

Definitely download the most recent drivers for your hardware. There have been changes to the driver infrastructure between the different versions of 10. As per my post above, microsoft calls them all “Windows 10” but under the hood there’s a huge amount of change going on, and shit breaks… make sure all your drivers are 20h2 compatible versions.

do you have any anti telemetry host blocks? say by spybot anti beacon?
or edited the host file yourself to block telemitry?
if so save a copy to another folder. and restore the original hosts. then run the update again…

i forgot that anti beacon can cause win 10 to bawk its updates if the host file has some of the MS update servers blocked…
so yeah set the host file to its defaults. and try again.

1 Like

Host file method modification by blocking Win10 telemetry addresses is now forbidden by Windows Defender itself.

You dont own your Win 10 operating system anymore. Its Microsoft’s OS and not yours to modify.

1 Like

I will say I think it is very brave of you to run windows 10 on a Gateway system.

Have you run the windows update shotgun blast DISM.exe /Online /Cleanup-image /Restorehealth & sfc /scannow ? I have never seen those commands fix anything, but you never know you might get lucky.

I had an HP laptop that needed a firmware update so Windows 10 1703 could be upgraded to the latest version (20H2). Perhaps it is your case.

nope you can still do it…
i have it done. you make the host file read only and if you have the option set your antivirus to stop changes to the host file.
but making it read only works just as well if you cant.