Return to Level1Techs.com

Windows RAID 0 array dissapears in one place, reappears in another?

TL;DR:
How does one windows instance “steal” a RAID 0 config from another after BIOS update?? (WIN10A, where the array was created, lost sight of the RAID0 array, but it magically just worked in WIN10B, which is on another drive.)

What is the expected behaviour if I create a RAID 0 array in Windows? Should all instances of Windows on the computer work fine with it? Or only 1?


I updated my BIOS on my mobo to AGESA 1.0.0.4b and had something really unexpected happen, and I’m wondering if anyone can explain why/how. I’m only trying to figure it out cuz I’m curious. I didn’t lose any files and please no lectures on why I shouldn’t be running RAID anyway.

My setup:
Asus X470-F Gaming
970 Evo Plus 512GB as first boot (Windows Boot Manager) - Win 10 PRO (WIN10A)
Crucial MX500 - WIN 10 PRO OLDER INSTALL (WIN10B)
Liquid LQD3000 - 4x 1.6TB NVME SSDs (Testing / RAID 0 array created in WIN10A)
bla bla bla

Other context: Before all this, I was messing around with RAID things, and the net result is the WIN10A instance seems to boot when BIOS is set to either AHCI OR RAID, but ONLY IF “nvme raid support” is set to enabled. Weird, cuz I only have the one nvme on the board but whatever. Otherwise I get blue screen and “INACCESSIBLE BOOT DRIVE”… even when I go safe mode.

The MX500 doesn’t work in RAID at all - just fails immediately on selection in Windows Boot Manager. I never installed AMD raid drivers on that windows instance so that’s probably why. Whatever, I need to switch the AHCI to boot into that instance.

Ok, weirdness:

  1. I used WIN10A to create a 4x RAID 0 array with my LDQ3000 drives (in Disk Management). Worked fine. Synthetic benches amazing. bla bla. Storage Spaces was trash by the way. No matter what I did it didn’t seem to create a RAID 0 array.

  2. Updated BIOS 1.0.0.4b and messed something up with WIN10A. Maybe because I’d put the pagingfile onto my LQD3000 array I thought. Maybe because I’m an idiot and I didn’t switch to RAID or turn nvme support on in BIOS on first reboot. (Eventually I fixed it and am able to get in fine btw).

  3. BUT… I booted into my OLD WIN10B instance (in AHCI) and to my great surprise, my LQD3000 RAID 0 array was there! Working, fast as ever, files accessible… just running along. This copy of windows had NOTHING to do with this array and I was quite shocked that it just worked with it.

  4. On the other hand… in WIN10A (where I’d set the frickin thing up!), my RAID 0 LQD3000 array ceased to exist. Drives show in disk management but as “GPT Protective Mode” and I literally can’t do anything. Everything is greyed out. “Converting disk to a Dynamic Disk” says it “doesn’t have enough free space” to do that. Whatever… cmd -> diskpart -> clean… now I’ve unlocked it.

  5. But of course going back to WIN10B, I’ve now killed the array. AND … AND!.. WIN10B now shows it in “GPT Protective Mode”… even though all 4 are completely uninitiated disks in WIN10A.