Windows installs wrong drivers

I run 2 GPU’s in my system a gtx 1660 ti and a gt 220 to use as a host for vfio.
When I run windows normally it keeps trying to install the old gt 220 drivers next to the ones of the gtx 1660 ti but those don’t have overlapping drivers in windows so every time I restart my windows machine it goes to the default VGA drivers because windows can’t get the gt 220 drivers to run, and the GTX 1660 ti get uninstalled by windows.

How can I prioritize my 1660 ti over the gt 220 in windows so it wont try to remove the drivers every time?

Try disabling driver downloads.

advanced system settings -> hardware tab -> device installation settings -> no downloads

Which GPU is in the first PCI-E slot?

GTX 1660 ti is in the first slot, disabling driver downloads did work better for quite a few restarts but somehow it still lost the drivers.