Windows install fails at 0%

I am trying to install Windows 10 on a Crosshair VI Hero and a Samsung 960 Pro.

I used to have Windows and Linux installed before. I wiped all drives, and I tried to reinstall Windows without any success.

I have other drives in the system, I disabled the SATA controller in the UEFI, but I get the same error.

Things I have tried:

  • CMOS clear
  • reflashing the UEFI (both latest stable and beta)
  • turning on/off CSM
  • turning on/off secureboot
  • different usb drive

This is the log when all drives are enabled:

This is the log when I disable SATA, so Windows only sees the NVMe SSD:

I tried to install Windows to the other drives, but I get similar failures.

Have you enabled EFI boot (and/or disabled legacy boot) in the bios?

I tried EFI only, and then I enabled CSM. It makes no difference.

Have you tried multiple install media? have you checked the .iso checksum? does linux still install properly?

  • Multiple Iso's -- perhaps you are using a corrupt one?
  • Check health of the drive

So far I was trying the creators update, now I tried the anniversary one, same results.

I tried the creators update and the anniversary update on two different USB sticks. I downloaded the creators update twice, both images had the same checksum.

I have just installed Ubuntu without any issues.

Playing around with manual partitioning, I could get this far:

It's a different error now.

mabye its trying to tell you to install linux


Always test the RAM.

I ran memtest for ~2 hours, as well as realbench stress test for about half a day.

OK. Also, remove all USB devices except mouse and keyboard.
BIOS reset using jumper/button on motherboard
wash, rinse, repeat

i would get the samsung nvme drivers :

load them up in appropiate install point of the win10 installer.

also do the same for amd chipset drivers

load them up also …

hopefully that will get you installing . and into windows 10