Return to Level1Techs.com

Windows Games on Steam for Linux. [Proton client Testing grounds]

steam-play

#405

Try Fedora 28 with KDE Desktop?


#406

I’ve tried Fedora and the Arch based distros like Manjaro and Antergos. They all did the same. I’ve had a lot of problems since Intel’s problems with Meltdown and Spector. If I knew then what I know now, I would have waited a few months and gone with AMD, but when I bought these computers, AMD was looking like it was heading for bankruptcy. It’s hard to predict anything in the tech industry.


#407

Here’s Command and Conquer with Spore thrown in.

These are the only C&C games available on Steam.
Command and Conquer 3: There’s a weird glitch in the settings that only recognizes my computer as having 1280x720 but if you click on it it displays my native resolution of 1366x768. Other than that it’s flawless.
Command and Conquer Kane’s Wrath: Same.
Command and Conquer Uprising: Same.
Command and Conquer Red Alert 3: Same as above but takes two minutes to launch.
Command and Conquer 4: Won’t launch. I suspect DRM in this or my computer has become self aware and is trying to spare me from this rubbish game.

Spore: Flawless
Spore Creature Parts: Won’t launch
Spore Galactic Adventures: Won’t launch

The two expansion packs are bundled with the base game. The Creature Pack is literally a cosmetic DLC pack. This should run. The second one should run as well. I’m thinking that this is a DRM issue.

Ubuntu 18.04
Intel® Core™ i5-7200U CPU @ 2.50GHz × 4
Intel® HD Graphics 620 (Kaby Lake GT2)
8.0 gb ram
3.0 Mesa 18.1.7
Kernel 4.15-33
Proton 3.7-3


#408

:large_orange_diamond: GTA:SA - works, but the game freezes sometimes on world load.


System:

  • CPU: Intel® Xeon® CPU E31240 @ 3.30GHz
  • GPU: Sapphire Toxic Radeon R9 270X
  • RAM: 24GB DDR3 @ 1333MHz
  • OS: Arch Linux Linux 4.18.5-arch1-1-ARCH
  • DE/WM: plasma-desktop 5.13.5-1 / kwin 5.13.5-1
  • GPU Drivers: xf86-video-amdgpu 18.0.1-2
  • OpenGL: mesa 18.1.7-1
  • Vulkan: vulkan-radeon 18.1.7-1
  • LLVM: llvm-libs 6.0.1-4 clang 6.0.1-2

:large_orange_diamond: - Works, but has some major problems


#409

You need a newer LLVM, like LLVM Git. LLVM 6 is shunned upon by the DXVK devs and should not be used with DXVK.


#410

GTA:SA uses DirectX 9.0, you shouldn’t need a newer LLVM to run it, since it doesn’t use dxvk.


#411

Anyone have any luck getting Uplay to work with Steam Play? Seems like some have had luck with Lutris, but I don’t see any reports of Uplay working under Proton.


#412

Hi,

I was asked by someone on Steam to report results here:

https://spcr.netlify.com/

To fill in one of these for each game tested:

You can see game reports here:

https://spcr.netlify.com/raw-reports

I also went on Discord Site to point to this thread.

Bye.


#413

added to the op.


#414

Thank you for all the work you have done, by creating this thread, and helping everyone out with the testing.

I think I have done all I can to point AMD Community Forum, AMD, Steam, and some of the Game Developers to this thread and various test videos.

I am hoping some effort will be made to make sure that some of the newer AAA games such as Warhammer: Vermintide II /Hunt Showdown/ Strange Brigade/ Sniper Elite 4 get some attention to see if something can be done to get them working with Steam Play Beta as soon as possible.

Bye.


#415

Not yet…I am still away this week…I might try during the weekend.


#416

Bioshock.

Bioshock: Runs a little choppy especially when the need for framerates increases (like when a splicer is attacking you). Sometimes it pauses outright.
Bioshock 2: Same
Bioshock Remaster 1 and 2: The launch banner appears and then crashes.
Bioshock Infinite: Linux port

Ubuntu 18.04
Intel® Core™ i5-7200U CPU @ 2.50GHz × 4
Intel® HD Graphics 620 (Kaby Lake GT2)
8.0 gb ram
3.0 Mesa 18.1.7
Kernel 4.15-33
Proton 3.7-3


#417

occasionally i do try to add more than just shitposting in the lounge :stuck_out_tongue:

you and others have added greater contributions im just the thread master :+1:


#418

Yeah I know that newer LLVM is better, but when i tried to install it from AUR it failed to compile. I am too lazy to figure it out atm.


#419

I managed to get Rocksmith running on Fedora 28 (kernel 4.17.19). At first it wouldn’t start at all but I changed the “Compatibility Tool” under Settings\Steam Play to “Photon 3.7.5 Beta” and it started.

Unfortunately although Rocksmith seems to run OK, I can’t play it because it’s not recognising the USB Tone Cable :frowning:

I saw that you mentioned in the Linux 1 Year Challenge thread that Rocksmith is running well for you now, are you using the USB Tone Cable? Where there any other things you tweaked to get it working?

Cheers.


#420

Whoa… Anyone who’s on the Experimental build of Subnautica just had their OpenGL renderer completely break when using Proton?

Recent updates did say they’ve taken efforts to compress game assets, but I didn’t expect that to break Proton…


#421

Yes i am, though not through Steam Linux. I installed Steam Windows through wine. The important bits where changing the Sound Engine to Alsa through winetricks and assigning the Audio Devices (Your output and the realtone Cable) through winecfg. In Rocksmith.ini you need to disable the Win32UltraLowLatency bit. After that it was working for me.

It’s still a bit finicky for me as i have 5 Audio Output devices (for Recording purpose). So changing Audio Level in Game doesn’t work for me (Rocksmith is playing through a different Audio Device than the Rest of the System). But if you’ve got a standard Audio Setup it should be fine.

I have not tested the in game Latency as i’m using my Kemper Profiler for Tones and have the in game Guitar Sound disabled. Reports on the internet state that it’s decent though.


#422

I am reporting a summary of my testing on the AMD Community Forum at the following location:

https://community.amd.com/thread/231494

You will be able to read the summary of my testing results there once I write them up.

You do not need an account on the AMD Community Forum to see the post.

However if you want to get AMD attention to this post, you can get an account here: https://community.amd.com/login.jspa?registerOnly=true

You are entitled to an account provided you own AMD CPU or GPU.

It would help get AMD attention on Steam Play Beta if you could “like” any videos or posts I make on there, if you do like them of course. Also please feel free to ask questions about any of the videos I posted on there or about the testing report summary that I will be posting soon.

Also please feel free to add any comments on the post related to your own testing of AMD cards with Steam Play Beta. Please respond to the original post if you do so. Please adhere to the AMD Community forum rules if you do go on the thread. Please be as polite as possible.

I am trying to get AMD to work with some of the game devs and Steam to help get newer AAA titles running on Linux with AMD GPU as soon as possible.

I have not started testing Nvidia cards yet, but the Nvidia forum is the place to repeat this process.
Many AMD forum users do not like you even mentioning Nvidia GPU’s at the moment, as I recently found out to my own cost, after I estimated the performance of new Nvidia RTX2080Ti versus an RX Vega 64 Liquid.

Thanks.


#423

Found out what was wrong with Subnautica Experimental. They switched to 100% streaming assets with an update to Unity 2018. Stay away from Subnautica once it changes to Unity 2018. Disable updates if it currently works for you.


#424

Seerious Sam.

Serious Sam First Encounter Classic: It runs but the graphics glitch so bad that it looks like a Steam game that Jim Sterling would make fun of.
Serious Sam Second Encounter Classic: Second verse same as the first
Serious Sam Revolution: Won’t launch
Serious Sam Double D XXL: Is this a game or a really big bra? It doesn’t launch anyway
Serious Sam 3: Linux port
Serious Sam Fusion: Linux port
Serious Sam First and Second Encounters HD: Won’t launch.
Serious Sam Random Encounter: Flawless
Serious Sam 2: Flawless

I know there are more games in this but I don’t have them. I bought this bundle after hearing about that Digital Devolver thing on E3. I saw comments about Serious Sam. I’d never heard of it, but I saw that is was put out by the same team that put out Talos Principle and gave it a shot. It sat on the back burner because I thought the titles were confusing but thought I would test it out on Steam Play. I have to say that these are the funnest games I have played in years. I love the arcade feel and look to them.

Ubuntu 18.04
Intel® Core™ i5-7200U CPU @ 2.50GHz × 4
Intel® HD Graphics 620 (Kaby Lake GT2)
8.0 gb ram
3.0 Mesa 18.1.7
Kernel 4.15-33
Proton 3.7-3

Finishing up the franchises.

Mount and Blade: Flawless
Mount and Blade Warband: Flawless
Mount and Blade with Fire and Sword: Flawless.