Return to Level1Techs.com

Windows Games on Steam for Linux. [Proton client Testing grounds]

steam-play

#385

Hi,

Thanks for watching the DOOM Video 2 above to see the low FPS with Vulkan API in DOOM on Fedora 28 problem I described.

I tried alt+tab out and back into DOOM before and it does not improve the FPS. I just reran DOOM to check again. alt+tab to another application or ald+enter to go from windowed to full screen makes no difference to the FPS either.

I think the reason I see poor Vulkan Performance in DOOM 2016 on Fedora 28 is as follows.

The now renamed Radeon™ Software for Linux® which contains the AMDGPU All-Open and AMDGPU-Pro Driver is not available for Fedora 28. I think this is also the case for a number of other Linux Distributions.

More information can be found here:
https://www.amd.com/en/support/kb/release-notes/rn-prorad-lin-18-30

The only driver officially available for Fedora 28 is the Mesa Driver.

It does look like there is a project on Github which attempted to provide the AMDGPU All-Open and AMDGPU-Pro Driver for an earlier version of Fedora. I will attempt to contact the developer about that.

I see very good Vulkan Performance on DOOM on UBUNTU 16.04 LTS with the “Radeon™ Software for Linux®” AMDGPU-PRO driver installed.

I demonstrated that last week in this video, which I repeat here only for your convenience:

I immediately tested Steam Play Beta when I read the announcement about it on DOOM 2016 on my Ubuntu 16.04 LTS installation which I was running at the time.

This, along with your feedback points me to the initial conclusion that the Mesa Drivers have poor Vulkan Performance.

I think the best place for me to continue to investigate this issue is to ask on the Fedora and AMD Community Forums.

If I find out any more information about this I will report back here on this Forum.

Thank you again for taking the time to reply to my question.
I really appreciate your help and feedback.

Bye.


#386

Okay. Divinity franchise results.

Divinity, Beyond Divinity, Divinity II Developer’s Cut, Divinity Original Sin Classic are all flawless.
Divinity Original Sin 2 is not owned,

Ubuntu 18,04Intel® Core™ i5-7200U CPU @ 2.50GHz × 4
Intel® HD Graphics 620 (Kaby Lake GT2)
3.0 Mesa 18.1.7
Kernel 4.15-33


#387

I think I worded it badly. The game is just old, doesn’t have options to change to high resolution, it doesn’t scale well or provide filters. Especially at 1440p/27" it looks pretty awful.
This is inherent flaw with this kind of game though, the important thing is it’s running just fine with no bad performance on my system.


#388

Max Payne - works great. No issues.

Deus Ex - started with the mouse cursor being really unstable and wobbling about. As soon as set the resolution correctly and restart the game, perfect.


#389

Somebody wanted video. Here’s a snippet of gameplay from Divinity: Original Sin 2 under a custom build of wine-staging 3.11. Pardon the audio quality, but OBS seemed to have some issues capturing the sound. In-game audio is flawless.

Steam Play works with some finagling, but the audio is crappy, so I resorted to my Fallout 4 Wine install and everything just worked.

“If there’s no video, it didn’t happen.”


#390

Interesting, I have played Grim Dawn the whole day yesterday with some on and off times on Steam with Steam Play, without any issues! The only issue I had was the first time I run the game the main screen character and surrounding textures were flickering. But other times everything was perfect!


#391

I’ve noticed this isn’t happening to everyone, but it’s definitely been discussed on the grim dawn forums, Reddit, and I saw it noted on the compatibility spreadsheet that’s been going around.
Definitely need to be sorted out because it’s pretty game breaking of it affects you.


#392

Here we go with Total War.

Medieval and Shogun. I didn’t attempt. No one has ever gotten either of these games to run on linux plus they won’t run on this computer in Windows 10
Rome Total War: It runs but the faction menu will freeze in a short time. Click your faction and set your difficulty quickly and press the next arrow as quickly as possible.
Alexander Total War: Same thing only it crashes to the desktop even quicker. You don’t have time to set difficulty.
Medieval 2: Linux port
Empire: Linux port
Napoleon: Campaign runs fine but crashes when you transition to the battlemap. This started in Windows on my desktop only it bounces back. It doesn’t here.
Shogun 2: Linux port
Rome 2: The launcher loads but when you enter the game it will crash.
Atilla: Linux port that won’t load past the splash screen
Warhammer 1 and 2 and Britannia: Not owned.

Ubuntu 18.04
Intel® Core™ i5-7200U CPU @ 2.50GHz × 4
Intel® HD Graphics 620 (Kaby Lake GT2)
3.0 Mesa 18.1.7
Kernel 4.15-3
Proton 3.7-3


#393

Here’s Witcher.

Witcher: flawless.
Witcher 2: Linux port
Witcher 3: It’s kind of hard for me to judge the performance on this game. It launched and played but it was so choppy that it was unplayable. It wasn’t the fault of Proton but my hardware. I’m just going to say it runs.

Ubuntu 18.04
Intel® Core™ i5-7200U CPU @ 2.50GHz × 4
Intel® HD Graphics 620 (Kaby Lake GT2)
8.0 gb ram
3.0 Mesa 18.1.7
Kernel 4.15-33
Proton 3.7-3


#394

Endless legend -tested not working
freezes on launch or system lock up needs hard reboot

18.04 ubuntu lts
ryzen3 1200
zotac 1070mini8gb
8gb ram
proton 3.7-3


#395

Here is Civilization and it’s ugly.

Civ 1 and 2: Not available on Steam
Civ 3: Launches but the menu shifts to the left and the buttons are unresponsive. Won’t play.
Civ 4: Greeted with over a dozen XML error messages that need to be closed manually. The menu launches with broken links. Won’t play.
Civ 4 expansions: Did not attempt due to the base game not running.
Civ 5: Hey! This one runs:)…Linux port.
Civ 6: Not owned.

Ubuntu 18.04
Intel® Core™ i5-7200U CPU @ 2.50GHz × 4
Intel® HD Graphics 620 (Kaby Lake GT2)
8.0 gb ram
3.0 Mesa 18.1.7
Kernel 4.15-33
Proton 3.7-3

Tested Fallout Tactics: Will not launch.


#396

Have you installed the latest version of Divinity?


#397

Witcher III : Wild Hunt performance here:


#398

Looks pretty good. I wish I could install Linux on my gaming rig and it would probably do just as well,


#399

Hi,

I think it looks pretty good. Vokoscreen Recorder does not really do it justice.
The FPS slightly lower but similar to running the game at those settings on Windows 10.

However in Windows 10 I can run the R9 Fury X in Crossfire with an R9 Nano in which case I can run the game at 2K Ultra 60FPS.

Why can’t you install Linux on your gaming rig?
All you should need is a new/spare SSHD or SSD drive, download Ubuntu or Fedora ISO and burn it to the drive. If you have an Nvidia GPU the proprietary GPU drivers are available. If Fedora 28, Mesa drivers are available for AMD cards… If Ubuntu 16.04/18.04 then AMDGPU drivers are installed.

Right now based on what I am seeing there is a performance hit in terms of FPS and for me, no DX11 Crossfire or DX12 MultiGPU is bad. But … that is a small sacrifice compared to the massive benefit of being able to drop Windows 10 where it should be. In the Linux desktop wastebasket.

Bye.


#400

I’m getting a pcie error and it creats an error logs in a continous and rapid loop that fills my usb stick before I can install. I’m not the only person who has trouble with this. It’s the same as this but more sever. I’d like to try the fix but I can’t even open the terminal to do it. Hell, most of the time it just goes black and fills my screen with spam.


#401

Screenshot%20from%202018-09-05%2005-25-00

This is all I get. So much for a whitelist.


#402

I have to stop testing for a while, because one of my harddrives bricked itself somehow, by going from NTSC to RAW format. I checked the integrity of the HDD and it seems OK. But something caused the boot record to go dead. Not sure how I can recover this issue. It was the drive with my Steam library and a few other things.


#403

*NTFS

You could try Spinrite to try to recover the MBR


#404

So is this like cutting vegetables with a credit card?

I want that to be a T-shirt, or maybe a gif of Ryan trying to cut vegetables with a credit card while Wendel just boots up Linux beside him and plays games.