Return to Level1Techs.com

Windows File Sharing


#1

So I’ve run into quite a few annoying issues just trying to get basic file sharing settings working for a testing network that is not connected to the internet.

I was wondering how to forcefully update the Network window in Windows Explore. Hitting refresh constantly does some effect, but it’s not very authentic. For example, computers that are no longer connected to the network will still appear after hitting refresh several times, even long after they have disconnected.

Another issue that I ran into is that I went through a lot of work and effort to try and get basic file sharing working, but what what ended up working was that all I did was set a single basic/generic text file on my desktop to be shared with myself (basically I was trying random options at this point) and ironically that is what made all of the files appear in the Windows Network Windows Explore window.

I am so confused as to how and why Windows or whatever is structured like this. I just don’t get it. Please help.


#2

Maybe start by noting what versions of windows you have on the network, and steps taken to share folders so far.

Have you disabled/enabled any features/services?

Information about the network? How many computers? DHCP or Static? DNS server or any method to resolve host names?


#3

2 computers, 1 running 8.1, the other ran 8.1 and 7. Basically tried enabling as many options in advanced sharing settings as possible to get the files and folders to show up -for both computers.

Only feature I have disabled is Internet explorer, which even then shouldn’t be any impact at all.

I don’t know how to find out if it’s DHCP or Static. DNS Server?

Method to resolve host names? Nope, I don’t even know what that is or why I would need it.


#4

The computers are still showing up because you need to flush your ARP cache.


#5

What is that and how would I do that?


#6

Run the following command in the command line as Administrator.

netsh interface ip delete arpcache


#7

ARP (Address Resolution Protocal) is an old protocol which caches MAC addresses to IP addresses. So when you type the IP of a computer on your network, say 192.168.1.xxx, the computer knows what the target MAC address is and doesn’t need to waste time searching for the client. If the IP address changes, then the cache will to be flushed or updated for the new address.

IIRC windows reads from the cache for the list of devices to connect to.


#8

I think it worked

I’ll report back with a fresh OS install, that should do the trick -to make sure that it’s not showing computers that are no longer on the network


#9

Okay, so it seems that it’s updating the list of computers on the network just fine, but being able to see the files and folders and user account folders is still an issue. I can’t get them to appear for other computers, and they have as many settings in Advanced Sharing Settings set to enabled as possible to make the files and folders appear. I don’t get it.

edit- upon further testing, it turns out that the netsh interface ip delete arpcache command prompt entry is not doing the trick either. It’s still showing computers that are not on the network after entering it several times and refreshing the Network window.

edit2- upon even further testing, even after entering the command prompt command for both computers several times, making sure that as many settings are turned on as possible, and restarting both computers, the files and folders still do not show up

This is really starting to piss me off. Fuckin Windows is so dumb…

edit3- Even my old method of trying to get the files and folders to appear just by right clicking a single basic file and selecting share isn’t working now either.


#10

Okay, so what I’ve learned from this so far is that it seems that it appears to be a Windows refreshing issue if anything. I still can’t get anything to show up.

I’ll try Windows 8.1 and Windows 7 and see if that works. My last tests were done with Windows 8.1 and Windows 8.1.


#11

So what are you issues now?

You just dont want to see old computers listed on the network tab?


#12

Computers that are no longer apart of the network. That and enabling file sharing.


#13

I mean what kind of network Active Directory Domain or workgroup or what?

You check the NTFS permissions


#14

I got file sharing working. Windows is fucking retarded. I can’t even guarantee that this will work for other systems, but these are the settings that I used/noticed worked:

Windows 8.1

Private (Current Profile)
-Network Discovery - On
–On
-File and Pritner Sharing - On
-HomeGroup Connections - Use user accounts
Guest or Public
-Network Dsicovery - On
-File and Printer Sharing - On
All Networks
-Public Folder Sharing - On
-Media Streaming - disabled/not set
-File Sharing Connections - Use 128
-Password Protected Sharing - On

Windows 7

When the network connection was made and prompted for the network location type,
the Home option was chosen.

Home or Work (Current Profile)
-Network discovery - On
-File and Printer sharing - On
-Public Folder Sharing - On
-Media Streaming - disabled/not set
-File Sharing Connections - Use 128
-Password Protected Sharing - On
-HomeGroup Connections - Use user accounts
Public
-Network Discovery - On
-File and Pritner Sharing - On
-Public Folder Sharing - On
-Media Streaming - disabled/not set
-File Sharing Connections - Use 128
-Password Protected Sharing - On


#15

Alright, almost done with my main reason for doing all of this annoying shit. Time to make a new/different thread.


#16

Do you want to change the title to solved if so?


#17

Well the Network window not being update even when hitting refresh and entering the terminal command and signing in and out several times didn’t solve that issue. I would appreciate a solution to that.


#18

Interesting on my machine just auto updates.


#19

What version of Windows are you running? 10?


#20

Sorry forgot to mension I have 7 and did a quick test with turning on and off one of my routers. It takes like 10-30 sec but it auto refreshes itself.