Windows and Mac Time Issue

Can't get the time to stay set for each OS, it keeps changing to incorrect times. I've tried the registry edit -

"To fix it, just hit Start and type regedit.exe in the search box. Hit Enter and navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation. Right click anywhere in the right pane and hit New > DWORD (32-bit) Value. Name it RealTimeIsUniversal, then double click on it and give it a value of 1.

Lastly, reboot into OS X, then reboot back into Windows. You should now notice that your clock actually displays the correct time."

and it won't work. It still keeps displaying incorrect times.
Just wondering how to fix this.

Maybe the time in your bios is set incorrectly.
That might cause the time back change everytime you reboot.
Go to check if your bios date and time are setted correctly.

This is a Windows problem and has been since the release. By booting into another environment, Windows is unable to properly verify launch data it saves during shutdown, which tampers with timestamps.

When the time in BIOS is set correctly, Windows time is behind by 10 hours. Every time I adjust the time in Windows, it changes the time in BIOS and it changes the time in BIOS to the incorrect time.

I hope you read what I said. It isn't a BIOS issue. It's a Win10 issue. Try setting Windows to use network time rather than system time. @Derbshey

Windows uses local time instead of UTC, unlike MacOS & Linux. I had similar issues dualbooting with Ubuntu.

You can try forcing local time in the other OS' or force Windows 10 to use UTC.

1 Like

Yup, it's this. I am dual booting Windows 10 and Ubuntu and had the same issue. There is a simple command to force Ubuntu to use local time instead of UTC. I imagine there is something similar for Mac but I don't know much about Mac OS.

There's a way to do it via terminal I believe. Normally, I just force Windows to use UTC, but I haven't had such luck with Windows 10 in my experience.

How would i do that?

How? I use 8.1 Pro, not 10

I was looking into this, and one simple work around without messing with the terminal is to just let Windows manage the time but set your time zone in OSX to London & uncheck set date & time automatically.